1 APT updates available

Unplugged power / re plugged the pi4 because the Projector didn’t pick up it’s HDMI signal once again, a random thing that comes and goes usually.
Picture was back but the Allo Boss DAC is not found, checked and it’s not loose, all pins are connected.

While trying to figure that one out via ssh, i saw there were 4 apt upgrades which i did and after reboot i still can see that there is one more update remaining which actually isn’t there if i try to upgrade it.

Before i waste to much time trying to figure out the DAC problem. (My guess is the on/off overcharged something), i am wondering if that might indicate in some way some known defect or broken system?

apt upgrade : Run now to apply 1 available APT package upgrades

Required Information

  • DietPi version
  • Distro version
    bullseye 0
  • Kernel version
    Linux DietPi 5.15.61-v8+ #1579 SMP PREEMPT Fri Aug 26 11:16:44 BST 2022 aarch64 GNU/Linux
  • SBC model
    echo $G_HW_MODEL_NAME
  • Power supply used | default pi4
  • SD card used | Allo Boss DAC

can you try following

/boot/dietpi/func/dietpi-set_software apt-cache clean
apt update
apt upgrade
apt full-upgrade
apt list --upgradable
sudo apt-mark showhold
1 Like

Can you show the output of:

apt update
apt list --upgradeable
cat /run/dietpi/.apt_updates

Probably a package was hold back. Did you also try apt full-upgrade?

EDIT: Ah lol doubled post :smile:.

1 Like

sorry guys, after plugging the DAC back in with Sound working again, the 1 APT still showed up but when i run

apt update
apt upgrade

there were 3 new packages available. After installing them the 1 APT bug went away, tried rebooting though the bug is gone.

Will come back to this thread and do your steps when i see it again, i do remember having this same 1 APT available behaviour years ago with dietpi.

Thanks, cheers!

1 Like

Okay great, probably new updates appeared just between the upgrade and the reboot before. On boot, it is checked for new packages.