Cannot upgrade DietPi Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
Bernie V
Posts: 23
Joined: Thu Jan 05, 2017 8:07 pm

Cannot upgrade DietPi

Post by Bernie V »

Hello,

Due to an old repository from Emby I cannot upgrade my DietPi installation.

Code: Select all

W: GPG error: http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04  InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0A506F712A7D8A28
I found here a way to renew the public key but that's not solving the problem.
Is there another way to solve this? Or where can I remove http://download.opensuse.org/repositori ... untu_14.04 InRelease

Code: Select all

#### Details:
- Date           | Thu Nov 18 10:34:32 GMT 2021
- DietPi version | v7.7.3 (MichaIng/master)
- Image creator  | DietPi Core Team
- Pre-image      | Raspbian Lite
- Hardware       | RPi 3 Model B (armv7l) (ID=3)
- Kernel version | `Linux VanDerMedMan 5.10.63-v7+ #1459 SMP Wed Oct 6 16:41:10 BST 2021 armv7l GNU/Linux`
- Distro         | buster (ID=5,RASPBIAN=1)
- Command        | `apt-get -q update`
- Exit code      | 100
- Software title | DietPi-Update

#### Additional logs:
```
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Get:2 http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04  InRelease [1551 B]
Hit:4 https://archive.raspberrypi.org/debian buster InRelease
Hit:3 https://download.mono-project.com/repo/debian raspbianbuster InRelease
Err:2 http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04  InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0A506F712A7D8A28
Reading package lists...
W: GPG error: http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04  InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0A506F712A7D8A28
E: The repository 'http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04  InRelease' is not signed.
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: Cannot upgrade DietPi

Post by Joulinar »

Not sure why you use this repository for Emby. You could use dietpi-software as we install Emby directly from GitHub repository https://github.com/MediaBrowser/Emby.Releases/

to remove the old Ubuntu source, you would need to have a look into /etc/apt/ to search for the configuration file and remove it

Code: Select all

grep -r 'opensuse' /etc/apt/
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Bernie V
Posts: 23
Joined: Thu Jan 05, 2017 8:07 pm

Re: Cannot upgrade DietPi

Post by Bernie V »

The binary file /etc/apt/trusted.gpg~ contains this. (but cannot read it)
Can I remove this file?

These files are in /etc/apt
apt.conf.d auth.conf.d preferences.d sources.list sources.list.d trusted.gpg trusted.gpg~ trusted.gpg.d
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: Cannot upgrade DietPi

Post by Joulinar »

pls share whole output of

Code: Select all

grep -r 'opensuse' /etc/apt/
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Bernie V
Posts: 23
Joined: Thu Jan 05, 2017 8:07 pm

Re: Cannot upgrade DietPi

Post by Bernie V »

This is the output:

Code: Select all

root@VanDerMedMan:/home# grep -r 'opensuse' /etc/apt/
/etc/apt/sources.list.d/emby-server.list:deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04/ /
Binair bestand /etc/apt/trusted.gpg~ bevat de gezochte tekst.
root@VanDerMedMan:/home#
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: Cannot upgrade DietPi

Post by Joulinar »

you can remove /etc/apt/sources.list.d/emby-server.list and try again

Code: Select all

rm /etc/apt/sources.list.d/emby-server.list
apt update
apt upgrade
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Bernie V
Posts: 23
Joined: Thu Jan 05, 2017 8:07 pm

Re: Cannot upgrade DietPi

Post by Bernie V »

This did the trick ;-)
Thanks a lot!!
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: Cannot upgrade DietPi

Post by Joulinar »

and try thinking on using dietpi-software to install emby as it will install 4.6
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Bernie V
Posts: 23
Joined: Thu Jan 05, 2017 8:07 pm

Re: Cannot upgrade DietPi

Post by Bernie V »

DietPi -> latest version
Emby -> latest version (via dietpi-software)

I think the reason was I were in a beta testprogram of Emby in the beginning.
Post Reply