How to install KODI 18.7 on Bullseye? Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: How to install KODI 18.7 on Bullseye?

Post by Joulinar »

Well Kodi is the very last app that is started during boot. Usually the Pi should be booting completely before kodi is going to launch.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
ISquishWorms
Posts: 32
Joined: Thu Jan 31, 2019 2:01 am

Re: How to install KODI 18.7 on Bullseye?

Post by ISquishWorms »

I have done some more testing and as a result I no longer think that this is a firmware bug as it happens when Kodi is set to autostart. If default terminal is set to start then HDMI output does not fail.

I used this command G_CONFIG_INJECT 'dtoverlay=vc4-kms-v3d' 'dtoverlay=vc4-kms-v3d,noaudio' /boot/config.txt and used dietpi-config to change autostart option to terminal (0) default. I rebooted the Pi3 and it displayed the login prompt on the TV fine.

I then used dietpi-config to change autostart option to Kodi (1) and rebooted. The Pi3 flashed some text on screen and appeared to be booting as usual. The Kodi screen never appears and HDMI output drops and does not return before the Kodi screen is ever shown.

I then SSH back into the server and issued another reboot command to see if just by simply rebooting HDMI would fire back up on the next attempt. However, it goes through the same process of looking like it is going to reboot and HDMI drops again. This is kind of expected as I did not change anything and only simply issued a reboot command. This time though I am unable to SSH back into the server and I get message SSH connection refused. So, I waited and tried to SSH in again and this time SSH did not respond the cursor just flashed as though it was trying to connect but was very slow. After waiting for a little while the Pi3 rebooted of its own accord so I am guessing that whatever it was doing or trying to do eventually caused it to crash completely. After it rebooted of its own accord HDMI dropped again but I was able to get back into it using SSH to remove the noaudio option from /boot/config.txt. Having removed noadudio the Pi3 will boot straight into Kodi.

The problem appears to be if Kodi is set to autostart and the noaudio option is set in /boot/config.txt.

I hope this information is of some use and it makes sense.
Post Reply