Error installing FPC on Raspi 4 with Dietpi Armv7

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
diver66
Posts: 7
Joined: Mon Mar 08, 2021 6:18 pm

Error installing FPC on Raspi 4 with Dietpi Armv7

Post by diver66 »

HI,

I am trying to install FPC on my Raspi 4, using the latest DietPi_RPi-ARMv7-Bullseye (32 bit Debian), I also tried DietPi_RPi-ARMv8-Bullseye (64 bit Debian),
problem is I am always getting the following error message :

sudo apt-get -y install fpc

The following packages have unmet dependencies:
libgtk2.0-dev : Depends: gir1.2-gtk-2.0 (= 2.24.33-2) but 2.24.33-2+rpt1 is to be installed
E: Unable to correct problems, you have held broken packages.


sudo apt-get install libgtk2.0-dev

The following packages have unmet dependencies:
libgtk2.0-dev : Depends: gir1.2-gtk-2.0 (= 2.24.33-2) but 2.24.33-2+rpt1 is to be installed
E: Unable to correct problems, you have held broken packages.

What can I do ?
User avatar
Joulinar
Posts: 6525
Joined: Sat Nov 16, 2019 12:49 am

Re: Error installing FPC on Raspi 4 with Dietpi Armv7

Post by Joulinar »

I guess you would need to use the ARMv6 image as the package you try to install require Raspbian repository instead of Debian repository.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
diver66
Posts: 7
Joined: Mon Mar 08, 2021 6:18 pm

Re: Error installing FPC on Raspi 4 with Dietpi Armv7

Post by diver66 »

okay thanks a lot, i'll install now and let you know, quick question could I not somehow add the raspbian sources ?, just shooting blanks :D
User avatar
Joulinar
Posts: 6525
Joined: Sat Nov 16, 2019 12:49 am

Re: Error installing FPC on Raspi 4 with Dietpi Armv7

Post by Joulinar »

not 100% sure on the side effect if you add Raspbian source as well.

Theoretically you could download the single deb package directly but it might have other dependency as well.

Code: Select all

root@DietPiProd:~# apt show libgtk2.0-dev
Package: libgtk2.0-dev
Version: 2.24.32-3+rpt1
Priority: optional
Section: libdevel
Source: gtk+2.0
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Installed-Size: 16.1 MB
Depends: libgtk2.0-0 (= 2.24.32-3+rpt1), gir1.2-gtk-2.0 (= 2.24.32-3+rpt1), libgtk2.0-common, libglib2.0-dev (>= 2.27.3), libgdk-pixbuf2.0-dev (>= 2.21.0), libpango1.0-dev (>= 1.20), libatk1.0-dev (>= 1.29.2), libcairo2-dev (>= 1.6.4-6.1), libx11-dev (>= 2:1.0.0-6), libxext-dev (>= 1:1.0.1-2), libxinerama-dev (>= 1:1.0.1-4.1), libxi-dev (>= 1:1.0.1-4), libxrandr-dev (>= 2:1.2.99), libxcursor-dev, libxfixes-dev (>= 1:3.0.0-3), libxcomposite-dev (>= 1:0.2.0-3), libxdamage-dev (>= 1:1.0.1-3), pkg-config (>= 0.26-1), libxml2-utils
Better to use ARMv6 image 8)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
diver66
Posts: 7
Joined: Mon Mar 08, 2021 6:18 pm

Re: Error installing FPC on Raspi 4 with Dietpi Armv7

Post by diver66 »

Thanks worked like a charm
User avatar
Joulinar
Posts: 6525
Joined: Sat Nov 16, 2019 12:49 am

Re: Error installing FPC on Raspi 4 with Dietpi Armv7

Post by Joulinar »

Did you used the ARMv6 image or how did you managed?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply