can't update. Cerificate errors

Having issues with your DietPi installation or found a bug? Post it here.
User avatar
MichaIng
Site Admin
Posts: 3357
Joined: Sat Nov 18, 2017 6:21 pm

Re: can't update. Cerificate errors

Post by MichaIng »

Confusing that this is even an issue on Bullseye :?. Can you show the following:

Code: Select all

dpkg -l | grep ssl
manilx
Posts: 133
Joined: Mon Dec 07, 2020 11:02 am

Re: can't update. Cerificate errors

Post by manilx »

Code: Select all

ii  libnet-ssleay-perl            1.88-3+b1                      amd64        Perl module for Secure Sockets Layer (SSL)
ii  libssl1.1:amd64               1.1.1k-1+deb11u1               amd64        Secure Sockets Layer toolkit - shared libraries
ii  libxmlsec1-openssl:amd64      1.2.31-1                       amd64        Openssl engine for the XML security library
ii  libzstd1:amd64                1.4.8+dfsg-2.1                 amd64        fast lossless compression algorithm
ii  openssl                       1.1.1k-1+deb11u1               amd64        Secure Sockets Layer toolkit - cryptographic utility
ii  perl-openssl-defaults:amd64   5                              amd64        version compatibility baseline for Perl OpenSSL packages
User avatar
Joulinar
Posts: 5998
Joined: Sat Nov 16, 2019 12:49 am

Re: can't update. Cerificate errors

Post by Joulinar »

Could you try switching back to HTTPS pls. We got feedback from Debian System Administrators and issue should have been fixed. At least for their repository.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
manilx
Posts: 133
Joined: Mon Dec 07, 2020 11:02 am

Re: can't update. Cerificate errors

Post by manilx »

Tried again.

Debian seems fixed now. Webmin still gives error.
User avatar
Joulinar
Posts: 5998
Joined: Sat Nov 16, 2019 12:49 am

Re: can't update. Cerificate errors

Post by Joulinar »

I guess something Webmin guys would need to fix, same way as Debian guys did
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
Joulinar
Posts: 5998
Joined: Sat Nov 16, 2019 12:49 am

Re: can't update. Cerificate errors

Post by Joulinar »

btw issue has been reported to webmin https://github.com/webmin/webmin/issues/1533
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
manilx
Posts: 133
Joined: Mon Dec 07, 2020 11:02 am

Re: can't update. Cerificate errors

Post by manilx »

I've read the whole thread.

The issue here was the ssl inspection of our Fortigate (at newest firmware and fully updated).
It cancelled the connections due to the certificate issues.
We had to disable ssl inspection for the time being.
It is not only old Ubuntu etc installations but up to date firewalls.

As I don’t have a login to post there you might inform them.

Thx!
Post Reply