install qmapshack (armel/armhf ?) on Raspberry 1B (armv6)

Suggestions for features and software you would like to see in DietPi, goes here.
Post Reply
64*super
Posts: 2
Joined: Wed Sep 29, 2021 2:40 pm

install qmapshack (armel/armhf ?) on Raspberry 1B (armv6)

Post by 64*super »

Ich nutze DietPi auf meinen Raspberry 1B (armv6) und möchte auf diesem qmapshack (https://packages.debian.org/search?keywords=qmapshack) installieren. Es wird mir über apt aber nur angeboten (als Version 1.7.2) , wenn ich auf eine ältere Version von DietPi zurückgehe (entsprechend Debian stretch) - Vielleicht, weil das Programm für armv6-Geräte aus den armel-Quellen gezogen wird? Auf der vorgenanten debian-Seite kann ich ja entnehmen, das qmapshack nur für stretch als Version 1.7.2-1 und stretch-backports als Version 1.11.1-1 in armel-Version zur Verfügung steht - ab buster nur als armhf. Kann mir jemand einen Tip geben, wie ich zumindestens 1.11 (stretch-backports) installieren kann - evtl. eben auch auf einer älteren DietPi-Version? Das wäre für mich sehr wichtig, weil Version 1.7.2 wichtige Features fehlen. Vielen Dank im voraus !

translation google:
I use DietPi on my Raspberry 1B (armv6) and want to install qmapshack (https://packages.debian.org/search?keywords=qmapshack) on it. I am only offered it via apt (as Version 1.7.2) if I go back to an older version of DietPi (corresponding to Debian stretch) - maybe because the program for armv6 devices is taken from the armel sources? On the aforementioned debian page I can see that qmapshack is only available for stretch as version 1.7.2-1 and stretch-backports as version 1.11.1-1 in the armel version - from buster only as armhf. Can someone give me a tip how I can install at least 1.11 (stretch-backports) - possibly also on an older DietPi version? That would be very important to me because version 1.7.2 lacks important features. Thanks in advance !
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: install qmapshack (armel/armhf ?) on Raspberry 1B (armv6)

Post by Joulinar »

Hi,

pls try to use English language. Even if we understood German, it's easier for other user to follow. Using Google Translate is totally fine. ;)

Basically DietPi version has no relation to Debian version. You will get same DietPi version on all supported Debian release. As well we don't offer any Stretch images anymore as it's oldold Debian release and we are planning to drop support in future.

Anyway in your case, I would recommend to update your installation to Debian Buster to get a newer package version

https://dietpi.com/docs/usage/#how-to-upgrade-to-buster
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
64*super
Posts: 2
Joined: Wed Sep 29, 2021 2:40 pm

Re: install qmapshack (armel/armhf ?) on Raspberry 1B (armv6)

Post by 64*super »

Thank you for reply and help!

yes - to work on Debian Buster would be much better - I know.
But with actually dietpi version I get on apt the following answer:

Code: Select all

" Reading state information... Done
Package qmapshack is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'qmapshack' has no installation candidate  "
Therefore I tried the stretch version of dietpi and got qmapshack with apt - but a very early version 1.7.2 - thats my problem.
Any idea to solve my problem?
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: install qmapshack (armel/armhf ?) on Raspberry 1B (armv6)

Post by Joulinar »

as stated above, there is no relation between DietPi version and Debian version but on new images we ship latest Debian version Bullseye by default. Did you tried the Buster or the Bullseye image. Maybe this package is not yet available on Bullseye.

To check OS version

Code: Select all

echo $G_DISTRO_NAME $G_RASPBIAN
If it return Bullseye, you could try old Buster image. https://dietpi.com/downloads/images/Die ... -Buster.7z
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
WarHawk
Posts: 781
Joined: Thu Jul 20, 2017 8:55 am

Re: install qmapshack (armel/armhf ?) on Raspberry 1B (armv6)

Post by WarHawk »

From their github page
https://github.com/Maproom/qmapshack/wiki
Unsupported Systems
Due to limited resources a few operating system versions are not supported:

Linux 32bit versions
Windows 32bit versions
OS X < 10.12
there is source in downloads...might be able to compile for ARM
Next to all dependencies you need a working GIT, g++ and cmake installation to compile QMapShack on your computer. Clone and compile the code base by:

git clone https://github.com/Maproom/qmapshack.git QMapShack
cd QMapShack
git checkout dev
cd ..
mkdir build_QMapShack
cd build_QMapShack
ccmake ../QMapShack
make

To update the code to the cutting edge do in QMapShack:

git pull

And change back to build_QMapShack:

make

Dependencies

* [Qt5](https://www.qt.io/) (at least 5.8)
* [GDAL](http://www.gdal.org/) (at least GDAL 2.3)
* [Proj4](https://proj.org/) (at least 7.2.1)
* [Routino](http://www.routino.org/) (at least 3.1)
* [QuaZip](http://quazip.sourceforge.net/index.html) (Qt5 V1.x)
* CMake/Make
* a C++ compiler (supporting C++11)
Did a bit of poking around to see if there is something that can make cmake crosscompile with ARM
https://github.com/vpetrigo/arm-cmake-toolchains
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: install qmapshack (armel/armhf ?) on Raspberry 1B (armv6)

Post by Joulinar »

@64*super
I was a little bit tricky but I was able to install qmapshack on our ARMv6 Raspbian Bullseye image

Unfortunately Raspbian Repository did not contain any *.deb package for qmapshack higher than version 1.7.2. But Debian repository does. Therefore I download the package from this source, plus 2 other dependencies.

Disclaimer You will do it on your own risk as you will sideload packages from a different repository.
The following was done on a RPi3B+ running DietPi v7.6.2 - ARMv6 Bullseye.

Code: Select all

cd /tmp/
wget http://ftp.debian.org/debian/pool/main/q/qmapshack/qmapshack_1.15.2-1+b1_armhf.deb
wget http://ftp.debian.org/debian/pool/main/q/qtwebengine-opensource-src/libqt5webenginewidgets5_5.15.2+dfsg-3_armhf.deb
wget http://ftp.debian.org/debian/pool/main/q/qtwebengine-opensource-src/libqt5webenginecore5_5.15.2+dfsg-3_armhf.deb
You would need to install packages one by one as they will pull quite some other packages in addition.

Code: Select all

apt install ./libqt5webenginecore5_5.15.2+dfsg-3_armhf.deb
apt install ./libqt5webenginewidgets5_5.15.2+dfsg-3_armhf.deb
apt install ./qmapshack_1.15.2-1+b1_armhf.deb
Now you could check packages installed

Code: Select all

root@DietPi3:/tmp# dpkg -l qmapshack
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-====================================================
ii  qmapshack      1.15.2-1+b1  armhf        GPS mapping (GeoTiff and vector) and GPSr management
root@DietPi3:/tmp#
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3357
Joined: Sat Nov 18, 2017 6:21 pm

Re: install qmapshack (armel/armhf ?) on Raspberry 1B (armv6)

Post by MichaIng »

Note that the Debian armhf packages won't work on Raspberry Pi 1 and Zero models. Also Debian does not provide them for armel (on Bullseye) which might be for the same reason why Raspbian does not provide them for armv6hf. Probably the later sources do simply not compile on ARMv6 for some reason. That may be asked for at Raspbian or Debian bug tracker to understand the reasons.
Post Reply