Can't install php7.3-curl after upgrade to buster Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
fhals
Posts: 35
Joined: Mon Sep 07, 2020 10:00 am

Can't install php7.3-curl after upgrade to buster

Post by fhals »

Hi,

after a nearly smooth upgrade from Debian Stretch to Buster, my php7.3-curl is gone (and so Nextcloud won't run- PHP-Module cURL not installed). php-m dosn't now about cURL either.

apt -y install php7.3-curl

gives back a

The following packages have unmet dependencies:
php7.3-curl : Depends: php7.3-common (= 7.3.29-1~deb10u1) but 7.3.30-1+0~20210826.87+debian9~1.gbpe56a7b is to be installed
E: Unable to correct problems, you have held broken packages.


What may be the best way to fix my PHP without breaking it for further Dietpi-Updates (now running 7.6.2)?

Any help will be appreciated,
thanks, Frans
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: Can't install php7.3-curl after upgrade to buster

Post by Joulinar »

Hi DietPi version has nothing to do with your current Debian version. Btw: Debian Buster has become oldstable some weeks back. Current Debian version is Bullseye.

Back to your issue: Your system is still trying to packages from Stretch repository (debian9)

Code: Select all

but 7.3.30-1+0~20210826.87+debian9~1.gbpe56a7b is to be installed
Could you check if all packages source files are updated? As well did you have done a reboot? As well you could try to clean apt cache

Code: Select all

/boot/dietpi/func/dietpi-set_software apt-cache clean
apt update
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
fhals
Posts: 35
Joined: Mon Sep 07, 2020 10:00 am

Re: Can't install php7.3-curl after upgrade to buster

Post by fhals »

Thank you for looking at this.

Cleaning apt-cache and update as suggested didn't change anything.
(Did this before like the dietpi hints noted).
Machine has been rebooted too.

/etc/apt/sources.list shows four lines of buster, no stretch.
As I performed the sed -i 's/stretch/buster/g' /etc/apt/sources.list{,.d/*.list} prior the upgrade, all stretch has changed to buster.

These are all the sources.lists I can find on the machine:

Code: Select all

/etc/apt/sources.list
/etc/apt/sources.list.d
/etc/apt/sources.list.d/dietpi-jellyfin.list
/etc/apt/sources.list.d/meveric-all-C2.list
/etc/apt/sources.list.d/meveric-all-main.list
/etc/apt/sources.list.d/meveric-all-testing.list
/etc/apt/sources.list.d/meveric-stretch-backports.list
/etc/apt/sources.list.d/meveric-stretch-main.list
Their contents are all bustered.

Where may this former source be hidden?

Thanks, Frans
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: Can't install php7.3-curl after upgrade to buster

Post by Joulinar »

Could you run following

Code: Select all

apt show php7.3-common
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
fhals
Posts: 35
Joined: Mon Sep 07, 2020 10:00 am

Re: Can't install php7.3-curl after upgrade to buster

Post by fhals »

Code: Select all

Package: php7.3-common
Version: 7.3.30-1+0~20210826.87+debian9~1.gbpe56a7b
Status: install ok installed
Priority: optional
Section: php
Source: php7.3
Maintainer: Debian PHP Maintainers <team+pkg-php@tracker.debian.org>
Installed-Size: 6,569 kB
Provides: php-calendar, php-ctype, php-exif, php-fileinfo, php-ftp, php-iconv, php-pdo, php-phar, php-posix, php-shmop, php-sockets, php-sysvmsg, php-sysvsem, php-sysvshm, php-tokenizer, php7.3-calendar, php7.3-ctype, php7.3-exif, php7.3-fileinfo, php7.3-ftp, php7.3-gettext, php7.3-iconv, php7.3-pdo, php7.3-phar, php7.3-posix, php7.3-shmop, php7.3-sockets, php7.3-sysvmsg, php7.3-sysvsem, php7.3-sysvshm, php7.3-tokenizer
Depends: php-common (>= 1:81~), ucf, libc6 (>= 2.17), libssl1.1 (>= 1.1.0)
Breaks: gforge-common (<< 6), php7.0-curl (<< 7.0.33-1~), php7.2-sodium (<< 7.2.12~)
Homepage: http://www.php.net/
Download-Size: unknown
APT-Manual-Installed: no
APT-Sources: /var/lib/dpkg/status
Description: documentation, examples and common module for PHP

N: There are 2 additional records. Please use the '-a' switch to see them.
--------
Just in case you might ask, this is the output with the '-a' switch:

Code: Select all

# apt show -a php7.3-common
Package: php7.3-common
Version: 7.3.30-1+0~20210826.87+debian9~1.gbpe56a7b
Status: install ok installed
Priority: optional
Section: php
Source: php7.3
Maintainer: Debian PHP Maintainers <team+pkg-php@tracker.debian.org>
Installed-Size: 6,569 kB
Provides: php-calendar, php-ctype, php-exif, php-fileinfo, php-ftp, php-iconv, php-pdo, php-phar, php-posix, php-shmop, php-sockets, php-sysvmsg, php-sysvsem, php-sysvshm, php-tokenizer, php7.3-calendar, php7.3-ctype, php7.3-exif, php7.3-fileinfo, php7.3-ftp, php7.3-gettext, php7.3-iconv, php7.3-pdo, php7.3-phar, php7.3-posix, php7.3-shmop, php7.3-sockets, php7.3-sysvmsg, php7.3-sysvsem, php7.3-sysvshm, php7.3-tokenizer
Depends: php-common (>= 1:81~), ucf, libc6 (>= 2.17), libssl1.1 (>= 1.1.0)
Breaks: gforge-common (<< 6), php7.0-curl (<< 7.0.33-1~), php7.2-sodium (<< 7.2.12~)
Homepage: http://www.php.net/
Download-Size: unknown
APT-Manual-Installed: no
APT-Sources: /var/lib/dpkg/status
Description: documentation, examples and common module for PHP

Package: php7.3-common
Version: 7.3.29-1~deb10u1
Priority: optional
Section: php
Source: php7.3
Maintainer: Debian PHP Maintainers <team+pkg-php@tracker.debian.org>
Installed-Size: 7,024 kB
Provides: php-calendar, php-ctype, php-exif, php-fileinfo, php-ftp, php-iconv, php-pdo, php-phar, php-posix, php-shmop, php-sockets, php-sysvmsg, php-sysvsem, php-sysvshm, php-tokenizer, php7.3-calendar, php7.3-ctype, php7.3-exif, php7.3-fileinfo, php7.3-ftp, php7.3-gettext, php7.3-iconv, php7.3-pdo, php7.3-phar, php7.3-posix, php7.3-shmop, php7.3-sockets, php7.3-sysvmsg, php7.3-sysvsem, php7.3-sysvshm, php7.3-tokenizer
Depends: php-common (>= 1:35), ucf, libc6 (>= 2.17), libssl1.1 (>= 1.1.0)
Breaks: gforge-common (<< 6), php7.0-curl (<< 7.0.33-1~), php7.2-sodium (<< 7.2.12~)
Homepage: http://www.php.net/
Download-Size: 936 kB
APT-Sources: https://deb.debian.org/debian-security buster/updates/main arm64 Packages
Description: documentation, examples and common module for PHP

Package: php7.3-common
Version: 7.3.27-1~deb10u1
Priority: optional
Section: php
Source: php7.3
Maintainer: Debian PHP Maintainers <team+pkg-php@tracker.debian.org>
Installed-Size: 7,024 kB
Provides: php-calendar, php-ctype, php-exif, php-fileinfo, php-ftp, php-iconv, php-pdo, php-phar, php-posix, php-shmop, php-sockets, php-sysvmsg, php-sysvsem, php-sysvshm, php-tokenizer, php7.3-calendar, php7.3-ctype, php7.3-exif, php7.3-fileinfo, php7.3-ftp, php7.3-gettext, php7.3-iconv, php7.3-pdo, php7.3-phar, php7.3-posix, php7.3-shmop, php7.3-sockets, php7.3-sysvmsg, php7.3-sysvsem, php7.3-sysvshm, php7.3-tokenizer
Depends: php-common (>= 1:35), ucf, libc6 (>= 2.17), libssl1.1 (>= 1.1.0)
Breaks: gforge-common (<< 6), php7.0-curl (<< 7.0.33-1~), php7.2-sodium (<< 7.2.12~)
Homepage: http://www.php.net/
Download-Size: 936 kB
APT-Sources: https://deb.debian.org/debian buster/main arm64 Packages
Description: documentation, examples and common module for PHP
fhals
Posts: 35
Joined: Mon Sep 07, 2020 10:00 am

Re: Can't install php7.3-curl after upgrade to buster

Post by fhals »

Found a solution using aptitude to handle this situation for me and perform a downgrade:

apt-get install aptitude
aptitude install php7.3-curl

Code: Select all

The following packages have unmet dependencies:
 php7.3-curl : Depends: php7.3-common (= 7.3.29-1~deb10u1) but 7.3.30-1+0~20210826.87+debian9~1.gbpe56a7b is installed
Aptitude then downgraded php 7.3.30 debian9 to php 7.3.29 debian10 to fix the dependencies:

Code: Select all

The following packages will be DOWNGRADED:
  php7.3-cli php7.3-common php7.3-fpm php7.3-gd php7.3-intl php7.3-json php7.3-mbstring php7.3-mysql php7.3-opcache php7.3-readline php7.3-xml php7.3-zip
The following NEW packages will be installed:
  php7.3-curl
After restarting lighttpd, my Nextcloud is up and running again.
Ready to upgrade to bullseye.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: Can't install php7.3-curl after upgrade to buster

Post by Joulinar »

Yesterday I had a chat with our developer and might know where this is coming from. We guess you had Ondrej's PHP repository configured before that got removed during the upgrade. Probably there are packages installed from this repository conflicting with the new one.

Ok let's try to remove them

Code: Select all

apt remove php7.3-common
If there are more packages listed, could you share them before confirmation.



EDIT: OK overlapping posting. 8)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply