[rpi 4 8gb] Can't start Kodi

Having issues with your DietPi installation or found a bug? Post it here.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: [rpi 4 8gb] Can't start Kodi

Post by Joulinar »

I will test Kodi on ARMv8 RPi4 once back home to be able to check screen output.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
igor
Posts: 2
Joined: Thu Oct 07, 2021 8:32 pm

Re: [rpi 4 8gb] Can't start Kodi

Post by igor »

Image

Same error here. I did a fresh install.

- RPI 4 (8GB)
- ARMv7 32-bit image (bullseye)

I tried a fresh install using ARMv8 64-bit image and Kodi worked. However, CEC doesn't work and we know 32-bit is more stable.

I have been using DietPi arm7 (buster) for a year and I have zero problems. I decided to upgrade to the bullseye, and I can't run Kodi anymore. Feeling that regret... :cry:
User avatar
MichaIng
Site Admin
Posts: 3357
Joined: Sat Nov 18, 2017 6:21 pm

Re: [rpi 4 8gb] Can't start Kodi

Post by MichaIng »

It works well on RPi Zero and RPi 2, so it is definitely an issue with the two HDMI ports on RPi 4, or another difference of the RPi 4 GPU. Btw, Kodi since Bullseye has native GBM support builtin on Debian as well, so it can be started without X server then as well. Would be interesting if this works:

Code: Select all

apt reinstall --allow-downgrade kodi
kodi --standalone
Also would be interesting if performance is fine with this Debian package. In case we can skip the own Kodi build on Bullseye for RPi 2 and up, or at least for RPi 4, depending on how well it performs.

So we need to find out how to force Kodi starting on the foreground screen.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: [rpi 4 8gb] Can't start Kodi

Post by Joulinar »

I have a RPi4B 8GB connected with a single HDMI port connected. HDMI 2 is empty. I could test Kodi but I'm nearly sure it was working in past. What version to test? ARMv6/7/8 ?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: [rpi 4 8gb] Can't start Kodi

Post by Joulinar »

@MichaIng

I did a test using RPi4B 8GB and it dosn't matter if I use ARMv7 or ARMv8. In both cases Kodi is started, but on a screen I'm not able to see. Unfortunately I have a single Micro HDMI cable only not being able to connect 2 screens at the same time. Therefore I couldn't check if Kodi is running on 2nd screen. Maybe I will need to get a 2nd Micro HDMI cable :? But best to my knowledge HDMI ports are not active if not connected. Still the question where Kodi is started on :roll:

Code: Select all

root       585   576  0 11:59 tty1     00:00:00 /bin/sh /usr/local/bin/kodi --standalone
root       617   585 14 11:59 tty1     00:02:14 /usr/local/lib/kodi/kodi-gbm --standalone
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3357
Joined: Sat Nov 18, 2017 6:21 pm

Re: [rpi 4 8gb] Can't start Kodi

Post by MichaIng »

Strange. But it must have something to do with the to ports, as on all other RPi models it works fine :?. Does it make a difference whether you use the --standalone flag or not?

And another interesting test would be whether the Debian Kodi package works:

Code: Select all

apt purge kodi
apt install kodi
kodi --standalone
EDIT: Ah, as you said 64-bit, means with the Debian Kodi package it's the same?
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: [rpi 4 8gb] Can't start Kodi

Post by Joulinar »

yes correct, it's same on our 32bit build as well as on the Debian 64bit build
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3357
Joined: Sat Nov 18, 2017 6:21 pm

Re: [rpi 4 8gb] Can't start Kodi

Post by MichaIng »

I'll have a look into the RPi build's scripts, I remember there was some workaround to switch to a different VT, probably it is exactly for that issue.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: [rpi 4 8gb] Can't start Kodi

Post by Joulinar »

but I'm pretty sure I had kodi working in past. Strange one.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply