Failed to upgrade from Debian Buster to Bullseye

Having issues with your DietPi installation or found a bug? Post it here.
alleyu2
Posts: 20
Joined: Sun May 03, 2020 8:52 am

Failed to upgrade from Debian Buster to Bullseye

Post by alleyu2 »

I am following the instructions on the DietPi blog to upgrade Debian Buster to Bullseye https://dietpi.com/blog/?p=811

I am on step 2.2.3. When I click on apt update, non of the packages are due for an upgrade. Am I doing something wrong? I tried restarting the system twice.

Code: Select all

apt update
Hit:1 https://download.docker.com/linux/raspbian bullseye InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian bullseye InRelease
Hit:3 https://downloads.plex.tv/repo/deb public InRelease
Ign:4 https://download.webmin.com/download/repository sarge InRelease
Hit:5 https://apt.sonarr.tv/debian buster InRelease
Hit:6 https://archive.raspberrypi.org/debian bullseye InRelease
Hit:7 https://download.webmin.com/download/repository sarge Release
Hit:9 https://download.mono-project.com/repo/debian raspbianbuster InRelease
Hit:8 https://packagecloud.io/golift/pkgs/ubuntu focal InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.
I am still on Buster.

Code: Select all

cat /etc/os-release
PRETTY_NAME=”Raspbian GNU/Linux 10 (buster)”
NAME=”Raspbian GNU/Linux”
VERSION_ID=”10″
VERSION=”10 (buster)”
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL=”http://www.raspbian.org/”
SUPPORT_URL=”http://www.raspbian.org/RaspbianForums”
BUG_REPORT_URL=”http://www.raspbian.org/RaspbianBugs”
Since there is no package update, apt upgrade and apt full-upgrade does not migrate me to Bullseye. Any help would be appreciated.
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by Joulinar »

Maybe there is a policy still active blocking your from updating your system. But I would not call it failed update as you even did not started ;)

Can you share following

Code: Select all

ls -la /etc/apt/preferences.d/
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
alleyu2
Posts: 20
Joined: Sun May 03, 2020 8:52 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by alleyu2 »

Joulinar wrote: Wed Sep 15, 2021 2:18 pm Maybe there is a policy still active blocking your from updating your system. But I would not call it failed update as you even did not started ;)

Can you share following

Code: Select all

ls -la /etc/apt/preferences.d/

Code: Select all

 ls -la /etc/apt/preferences.d/
total 12
drwxr-xr-x 2 root root 4096 Mar  1  2021 .
drwxr-xr-x 7 root root 4096 Sep 15 17:37 ..
-rw-r--r-- 1 root root  145 May 25  2020 pivpn-limit-bullseye
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by Joulinar »

ah you have PiVPN installed. As far as I can see PiVPN installer is setting the preference. Can you check if a source list is existing as well

Code: Select all

ls -la /etc/apt/sources.list.d/
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
alleyu2
Posts: 20
Joined: Sun May 03, 2020 8:52 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by alleyu2 »

Code: Select all

root@DietPi-Pi4:~# ls -la /etc/apt/sources.list.d/
total 52
drwxr-xr-x 2 root root 4096 Sep 15 17:38 .
drwxr-xr-x 7 root root 4096 Sep 15 17:37 ..
-rw-r--r-- 1 root root   79 Sep 15 17:36 debian-backports.list
-rw-r--r-- 1 root root   62 Sep 15 17:35 docker.list
-rw-r--r-- 1 root root   58 Sep 15 17:08 golift.list
-rw-r--r-- 1 root root   71 Sep 15 17:10 mono-xamarin.list
-rw-r--r-- 1 root root   59 Sep 15 17:38 pivpn-bullseye.list
-rw-r--r-- 1 root root   52 Sep 15 17:08 plexmediaserver.list
-rw-r--r-- 1 root root  226 May  5  2020 plexmediaserver.list.dpkg-dist
-rw-r--r-- 1 root root   58 Sep 15 17:08 raspi.list
-rw-r--r-- 1 root root   46 Sep 15 17:10 sonarr.list
-rw-r--r-- 1 root root   42 Sep 15 17:08 vscode.list
-rw-r--r-- 1 root root   67 Sep 15 17:08 webmin.list
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by Joulinar »

PiVPN sources as well as preferences list would need to be deleted.

Code: Select all

rm /etc/apt/sources.list.d/pivpn-bullseye.list
rm /etc/apt/preferences.d/pivpn-limit-bullseye
apt update
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
alleyu2
Posts: 20
Joined: Sun May 03, 2020 8:52 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by alleyu2 »

Thanks a lot. This worked :D :D
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by Joulinar »

our blog has been updated to reflect PiVPN being installed.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by Joulinar »

ADMIN EDIT: I moved the curl issue into the related topic to have all on one place viewtopic.php?t=9388
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
alleyu2
Posts: 20
Joined: Sun May 03, 2020 8:52 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by alleyu2 »

@Joulinar As discussed, I tried upgrading to bullseye and I got the following error with apt full-upgrade

Code: Select all

apt full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6+rpi1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Any help? The curl issue is now resolved
Post Reply