chromium wont launch - no packages found matching bluealsa

Having issues with your DietPi installation or found a bug? Post it here.
ryanramage
Posts: 4
Joined: Thu Sep 09, 2021 9:51 pm

chromium wont launch - no packages found matching bluealsa

Post by ryanramage »

Hey all, just getting going with dietpi, and I have a new setup where I install LXDE and am trying to launch chome but it wont start.

I check the /root/.cache/lxsession/LXDE/run.log and I see the following when I tail it after trying to launch chrome

Code: Select all

chromium-browser
dpkg-query no packages found matching bluealsa
and chromium does not launch. I think that is what is preventing the app from starting.

Any suggestions?
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: chromium wont launch - no packages found matching bluealsa

Post by Joulinar »

could you give some more details on your system pls

Required Information
DietPi version | cat /boot/dietpi/.version
Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
Kernel version | uname -a
SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)

Where do you have the issue eaxtly? Do you like to start Chromium on LXDE desktop or via autostart or on CLI?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
ryanramage
Posts: 4
Joined: Thu Sep 09, 2021 9:51 pm

Re: chromium wont launch - no packages found matching bluealsa

Post by ryanramage »

Here are the details you've asked for. I've transcribed them by hand...

Hope this helps some.

Code: Select all

cat /boot/dietpi/.version
G_DIETPI_VERSION_CORE=7
G_DIETPI_VERSION_SUB=5
G_DIETPI_VERSION_RC=2
G_GITBRANCH='master'
G_GITOWNER='MichaIng'
G_LIVE_PATCH_STATUS[0]='applied'

echo $G_DISTRO_NAME $G_RASPBIAN
bullseye 1

uname -a
Linux DietPi 5.10.60+ #1449 Wed Aug 25 14:59:20 BST 2021 arm6l GNU/Linux

echo $G_HW_MODEL_NAME
RPi B (arm6l)
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: chromium wont launch - no packages found matching bluealsa

Post by Joulinar »

You missed to answer my questions
Where do you have the issue eaxtly? Do you like to start Chromium on LXDE desktop or via autostart or on CLI?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
ryanramage
Posts: 4
Joined: Thu Sep 09, 2021 9:51 pm

Re: chromium wont launch - no packages found matching bluealsa

Post by ryanramage »

Oh I have tried all the ways now. I see this when I try and run from the command line, while LXDE desktop is running

Code: Select all

# chromium-browser
dpkg-query: no packages found matching bluealsa
Illegal instruction
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: chromium wont launch - no packages found matching bluealsa

Post by Joulinar »

@MichaIng
could you have a look pls. I guess bluealsa is not available on Bullseye RPi B (arm6l)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3216
Joined: Sat Nov 18, 2017 6:21 pm

Re: chromium wont launch - no packages found matching bluealsa

Post by MichaIng »

Why the hack is Chromium expecting the Bluetooth ALSA driver :?. Indeed it is not yet available on the Bullseye suite :(. Try to install it manually:

Code: Select all

cd /tmp
curl -sSfLO http://archive.raspberrypi.org/debian/pool/main/b/bluealsa/bluealsa_0.13_armhf.deb
apt install ./bluealsa_0.13_armhf.deb
rm bluealsa_0.13_armhf.deb
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: chromium wont launch - no packages found matching bluealsa

Post by Joulinar »

not really fixing the issue @MichaIng , just changed the error message

Code: Select all

root@DietPi1:~# chromium-browser
BlueALSA detected - Disabling audio sandbox
Illegal instruction
root@DietPi1:~# 
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3216
Joined: Sat Nov 18, 2017 6:21 pm

Re: chromium wont launch - no packages found matching bluealsa

Post by MichaIng »

Okay, so it is only "laudly" checked whether BlueALSA is installed do apply some workaround while the actual issue is a different one. Chromium just got upgraded yesterday: https://archive.raspberrypi.org/debian/ ... r/?C=M;O=D

Maybe it is the libraspberrypi issue backwards? :D
Although I guess libraspberrypi0 is up-to-date, isn't it?
User avatar
MichaIng
Site Admin
Posts: 3216
Joined: Sat Nov 18, 2017 6:21 pm

Re: chromium wont launch - no packages found matching bluealsa

Post by MichaIng »

The error does not show up on ARMv7.

Verified error on RPi Zero W. So the binary seems to be ARMv7 only, accidentally (?). Fits to the error message as well. I'll report to RPi devs.
Post Reply