Kodi Error

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Exatic
Posts: 5
Joined: Sun Oct 03, 2021 1:57 am

Re: Kodi Error

Post by Exatic »

Good evening. I took some of the ideas for a spin:

- Installed DietPI ARM64 on a new card. Kodi Autostart works fine but only as root. If I remember correctly it says something like /dev/tty0 permission denied during xinit() for dietpi user.
- I also did not get CEC-Module (TV remote to control Kodi) working. Historically, such issues have been resolved by unplugging pi & TV for 10 minutes. Did not get the chance to test myself but suggest to the user above who had the same issue.

Back to ARMv7 (Dietpi 32bit):
- Tried running Kodi from autostart as root on arm32. Still the same problem.
- Tried starting up as normal, and then switch the HDMI cable to port 2 when the Libva message occur. Nothing on the TV.
- Tried vcgenmod display_power 0 7. from terminal and restart Kodi. Same issue.
- Tried hdmi_ignore_hotplug:1=0 and hdmi_force_hotplug:0=1 in /boot/config.txt. Same issue.

While it has been an unsuccessful day, it is good to see it nothing wrong with my particular dietpi installation as other are experiencing the same problem.

A bit on the side. Is It worth changing to the ARM64 image for my RPI4 4GB? I did a extensive backup this morning in case it was my DietPi it was something wrong with, and it appeals to make the shift now when everything is ready and setup.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: Kodi Error

Post by Joulinar »

usually there is no real benefit of 64bit over 32bit.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
ISquishWorms
Posts: 15
Joined: Thu Jan 31, 2019 2:01 am

Re: Kodi Error

Post by ISquishWorms »

Good evening,

Just for clarification although I have a Pi3 and a Pi4 I am running Kodi on the Pi3. I have not tried running Kodi on my Pi4 although if it helps for testing I can because I backed it up only this morning and wiped the SD card for a fresh install of Bullseye. I decided to take the fresh install approach and reconfig/restore files manually rather than try and update to Bullseye.

So on my Pi3 (which I also wiped and installed Bullseye) I do get an error message when loading Kodi but its interface is displayed on the TV. I have not yet tried to play any video yet as I am unable to get the TV controller to work with Kodi, this was working prior to installing Bullseye.

@Exatic Thanks for the tip about unplugging the pi & TV for 10 minutes I will give this a try. It is probably just some setting I have set wrong but you never know it is worth a go. As for switching to 64bit, personally on my Pi4 (8 gig) I am taking the advice of DietPi support (Joulinar) along with MichaIng and sticking with 32bit at least until there is a stable final release of Raspberry Pi OS.

ISquishWorms.
igor
Posts: 2
Joined: Thu Oct 07, 2021 8:32 pm

Re: Kodi Error

Post by igor »

Image

Same error here. I did a fresh install.

- RPI 4 (8GB)
- ARMv7 32-bit image (bullseye)

I tried a fresh install using ARMv8 64-bit image and Kodi worked. However, CEC doesn't work and we know 32-bit is more stable.

I have been using DietPi arm7 (buster) for a year and I have zero problems. I decided to upgrade to the bullseye, and I can't run Kodi anymore. Feeling that regret... :cry:
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: Kodi Error

Post by Joulinar »

it doesn't make sense to post the same into 2 different topics, even if we have multiple of them open.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply