Wireguard on dietpi/vmware workstation

Having issues with your DietPi installation or found a bug? Post it here.
thejuan
Posts: 12
Joined: Wed Sep 01, 2021 7:35 pm

Re: Wireguard on dietpi/vmware workstation

Post by thejuan »

TL;DR: it suddenly worked. yay? Happy that it's working, not going to do massive root cause. Thanks for all the help!

I ran 'dietpi-software install 15' on both vm's, it did its thing, no errors.
I prepped the capture command line and had it in the consoles ready to go.

I switched my mobile to cellular, flipped the switch for wireguard
I launched chrome and forgot I had the pihole page up last...I hadn't started the capture yet... but it worked?!
I tested other internal sites and they all worked! Checked my ip via google and it was my home ip.
Stopped wireguard, sure enough no access. Switched it back on, back in my network!

So everything suddenly works.
Had to dive a little bit further so I started a new vm from scratch, wireguard first, and it worked out of the gate.
Tried to re-setup my original dietpi (is an older ver) but still had weird connectivity issues. Little bit boggled but I think I tripped up once and didn't create a new MAC for a new vm - threw me off course at some point I'm sure. I probably shouldn't be toking and tech'ing.

I ended up keeping the new new vm after I put pihole on it. It works, took a snapshot, and I've stepped away slowly.

Pretty inconclusive, maybe some weird networking issues somewhere...
Searching around though and connectivity with wireguard seems to be twitchy for a lot of people.
Appreciate the help and I'm keeping that tcpdump command, nice one-liner!
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Wireguard on dietpi/vmware workstation

Post by Joulinar »

Good it is working now, but indeed strange. Btw, you could have installed Pihole+ Wireguard on same VM. Much more resource friendly compare to running 2 VM's ;)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
thejuan
Posts: 12
Joined: Wed Sep 01, 2021 7:35 pm

Re: Wireguard on dietpi/vmware workstation

Post by thejuan »

good advice and it should work. I do have 2 vm's now, both with pihole, one with WG.
when I tried to point to the ip of the same server dns lookups didn't go through, though I haven't tried the 10. address yet. Got tired of dealing with it so I'll prob look at that tomorrow. cheers!
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Wireguard on dietpi/vmware workstation

Post by Joulinar »

Personally I'm running Pihole + Wireguard on a RPi and it's working fine.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply