problem while trying to upgrade to Bullseye following your blog post Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
manilx
Posts: 124
Joined: Mon Dec 07, 2020 11:02 am

problem while trying to upgrade to Bullseye following your blog post

Post by manilx »

Hi

I tried upgrading my pie4 (others would follow) by following: https://dietpi.com/blog/?p=811#2.2-manual-upgrade

After entering the command: apt upgrade

I get:

Code: Select all

Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  bsdextrautils cpp-10 gcc-10-base libcbor0 libcrypt1 libctf-nobfd0 libctf0 libdns-export1110 libfdt1 libffi7 libfido2-1 libgcc-s1 libgdk-pixbuf-2.0-0 libgdk-pixbuf-xlib-2.0-0
  libhogweed6 libisc-export1105 libisl23 libjson-c5 libjudydebian1 liblzo2-2 libmd0 libnetfilter-acct1 libnettle8 libnsl2 libprocps8 libprotobuf23 libreadline8 libsnappy1v5
  libusbmuxd6 libuv1 libxcb-util1 libxxhash0 libyaml-0-2 logsave mailcap media-types mksh ncal netcat-openbsd pci.ids python3-wheel rng-tools-debian runit-helper uuid-runtime
The following packages have been kept back:
  alsa-utils apt cpp-8 curl dh-python fio firefox-esr freeipmi-common galculator gcc-8-base gpicview htop iftop iperf iproute2 iptables libasound2 libasound2-data
  libauthen-pam-perl libc-bin libc-dev-bin libc6 libc6-dev libcairo-gobject2 libcairo2 libcolord2 libcurl3-gnutls libcurl4 libegl-mesa0 libexif12 libfm-gtk4 libfm4
  libfreeipmi17 libfreetype6 libgbm1 libgd3 libgl1-mesa-dri libglapi-mesa libglx-mesa0 libgtk-3-0 libgtk2.0-0 libimlib2 libinput10 libio-pty-perl libipmimonitoring6 libiptc0
  libiw30 liblcms2-2 libllvm9 liblocale-gettext-perl libnet-ssleay-perl libnspr4 libpam-systemd libpixman-1-0 libpng16-16 libpolkit-agent-1-0 libpolkit-gobject-1-0
  libpython2-dev libpython2-stdlib libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libpython3-dev libpython3-stdlib librados2 librbd1 librsvg2-2
  librsvg2-common libsensors5 libslang2 libsmbclient libsoup-gnome2.4-1 libsoup2.4-1 libsqlite3-0 libstdc++6 libsystemd0 libtcl8.6 libtext-charwidth-perl libtext-iconv-perl
  libtiff5 libtk8.6 libudev1 libvte-2.91-0 libwbclient0 libwebp6 libxml2 libxslt1.1 libxtables12 lightdm-gtk-greeter locales lxpanel lxpanel-data mawk perl perl-base php-apcu
  php-common policykit-1 python2 python2-dev python2-minimal python2.7 python2.7-dev python2.7-minimal python3 python3-dev python3-distutils python3-lib2to3 python3-minimal
  python3-psutil python3-rpi.gpio rpi.gpio-common samba-common samba-libs smbclient speedometer sqlite3 systemd tigervnc-standalone-server udev wpasupplicant xserver-xorg-core
  xserver-xorg-input-libinput
The following packages will be upgraded:
  adwaita-icon-theme base-files base-passwd bash bash-completion bc binutils binutils-arm-linux-gnueabihf binutils-common bsdmainutils bsdutils bzip2 ca-certificates
  cifs-utils console-setup console-setup-linux coreutils cpp crda cron dash dbus dbus-user-session dbus-x11 dconf-gsettings-backend dconf-service debconf debianutils
  device-tree-compiler diffutils dirmngr distro-info-data dmidecode dmsetup dns-root-data dosfstools dpkg e2fsprogs ethtool exfat-fuse fake-hwclock fdisk findutils
  firmware-linux-free fontconfig fontconfig-config fonts-dejavu-core fonts-font-awesome fonts-glyphicons-halflings fuse gcc-7-base gettext-base git git-man glib-networking
  glib-networking-common glib-networking-services gnupg gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm gpgv grep gsettings-desktop-schemas
  gtk-update-icon-cache gzip hdparm hfsplus hostname hwinfo idn2 ifupdown init init-system-helpers install-info iptables-persistent iptraf-ng iputils-ping isc-dhcp-client iw
  kbd keyboard-configuration kmod libacl1 libaio1 libapparmor1 libarchive13 libassuan0 libatk-bridge2.0-0 libatk1.0-0 libatk1.0-data libatomic1 libatspi2.0-0 libattr1
  libaudit-common libaudit1 libavahi-client3 libavahi-common-data libavahi-common3 libbinutils libblkid1 libbsd0 libbz2-1.0 libc-l10n libcap-ng0 libcap2 libcap2-bin
  libcom-err2 libcroco3 libcryptsetup12 libcups2 libdatrie1 libdb5.3 libdbus-1-3 libdbus-glib-1-2 libdconf1 libdebconfclient0 libdevmapper1.02.1 libdrm-amdgpu1 libdrm-common
  libdrm-nouveau2 libdrm-radeon1 libdrm2 libedit2 libegl1 libegl1-mesa libelf1 libepoxy0 liberror-perl libevdev2 libexpat1 libexpat1-dev libext2fs2 libfam0 libfdisk1 libffi6
  libfl2 libfm-data libfm-extra4 libfm-gtk-data libfontconfig1 libfontenc1 libfribidi0 libfuse2 libgcrypt20 libgdbm-compat4 libgdbm6 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgfapi0 libgfrpc0 libgfxdr0 libgif7 libgl1 libgles2 libglib2.0-0 libglu1-mesa libglusterfs0 libglvnd0 libglx0 libgmp10 libgnutls30 libgomp1 libgpg-error0 libgpm2
  libgraphite2-3 libgssapi-krb5-2 libgtk-3-common libgtk2.0-common libgudev-1.0-0 libharfbuzz0b libhd21 libhfsp0 libibverbs1 libice6 libidn11 libidn2-0 libimobiledevice6
  libinput-bin libjansson4 libjpeg62-turbo libjs-bootstrap libjs-jquery libjs-sphinxdoc libjs-underscore libjson-glib-1.0-0 libjson-glib-1.0-common libk5crypto3 libkeybinder0
  libkeyutils1 libkmod2 libkrb5-3 libkrb5support0 libksba8 libldap-2.4-2 libldap-common liblightdm-gobject-1-0 liblz4-1 liblzma5 libmagic-mgc libmagic1 libmenu-cache-bin
  libmenu-cache3 libmnl0 libmount1 libmpc3 libmpfr6 libmtdev1 libncurses5 libncurses6 libncursesw5 libncursesw6 libnetfilter-conntrack3 libnewt0.52 libnfnetlink0 libnftnl11
  libnghttp2-14 libnpth0 libnss3 libntfs-3g883 libobrender32v5 libobt2v5 libp11-kit0 libpam-modules libpam-modules-bin libpam-runtime libpam0g libpango-1.0-0
  libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libparted2 libpcap0.8 libpci3 libpciaccess0 libpcre2-8-0 libpcre3 libpcsclite1 libplist3 libpopt0 libproxy1v5 libpsl5
  libqrencode4 librdmacm1 librest-0.7-0 librtmp1 libsamplerate0 libsasl2-2 libsasl2-modules-db libseccomp2 libselinux1 libsemanage-common libsemanage1 libsensors-config
  libsepol1 libsgutils2-2 libsmartcols1 libsodium23 libss2 libssh2-1 libssl1.1 libstartup-notification0 libtalloc2 libtasn1-6 libtdb1 libtevent0 libtext-wrapi18n-perl
  libthai-data libthai0 libtinfo5 libtinfo6 libtirpc-common libtirpc3 libunique-1.0-0 libunistring2 libunwind8 libupower-glib3 libusb-1.0-0 libuuid1 libvncclient1
  libvncserver1 libvte-2.91-common libwacom-common libwacom2 libwayland-client0 libwayland-cursor0 libwayland-egl1 libwayland-server0 libwnck22 libwrap0 libx11-6 libx11-data
  libx11-xcb1 libxau6 libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxcb1
  libxcomposite1 libxcursor1 libxdamage1 libxext6 libxfixes3 libxfont2 libxi6 libxkbcommon0 libxkbfile1 libxres1 libxt6 libxxf86dga1 libzip4 libzstd1 lightdm lighttpd login
  lsb-base lsb-release lshw lsof lsscsi lxappearance lxde lxde-common lxde-core lxde-icon-theme lxhotkey-core lxhotkey-gtk lxinput lxlock lxmenu-data lxpolkit lxrandr
  lxsession lxsession-data lxsession-edit lxsession-logout lxterminal mc mc-data mime-support mount nano ncurses-base ncurses-bin net-tools netbase netcat netcat-traditional
  netdata netdata-core netdata-plugins-bash netdata-web netfilter-persistent ntfs-3g nvme-cli openbox openbox-lxde-session openssh-client openssh-server openssh-sftp-server
  openssl p7zip parted passwd pciutils pcmanfm perl-openssl-defaults pinentry-curses procps psmisc python-configparser python-pip-whl python-pkg-resources python-setuptools
  python3-pip python3-pkg-resources python3-setuptools qrencode readline-common rename rng-tools rsync sensible-utils sg3-utils shared-mime-info smartmontools stress sudo
  systemd-sysv sysvinit-utils tar tcl tcl8.6 tigervnc-common tk tk8.6 tzdata ucf unzip upower usb.ids usbutils util-linux wget whiptail wireguard-tools wireless-regdb
  wireless-tools x11-common x11-utils x11-xkb-utils x11vnc xarchiver xauth xcompmgr xfonts-encodings xinput xkb-data xserver-common xxd zlib1g
433 upgraded, 44 newly installed, 0 to remove and 124 not upgraded.
Need to get 148 MB of archives.
After this operation, 55.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Abort.
Problem is that when I enter Y (or y) it aborts.

Rolled back.

Pls advise.

Thx!!
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: problem while trying to upgrade to Bullseye following your blog post

Post by Joulinar »

Try to reboot and run the update again pls
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
manilx
Posts: 124
Joined: Mon Dec 07, 2020 11:02 am

Re: problem while trying to upgrade to Bullseye following your blog post

Post by manilx »

Worked. Updating.....

Will revert once finished.
User avatar
MichaIng
Site Admin
Posts: 3216
Joined: Sat Nov 18, 2017 6:21 pm

Re: problem while trying to upgrade to Bullseye following your blog post

Post by MichaIng »

Hehe, what appeared to be the universal Windows solution seems to work on Linux as well by times :). I faced a similar issue when waiting too long before confirming, although in combination with the apt-listchanges package to show me the changelog of all upgraded packages, which needs to be confirmed additionally. Not sure what happens with the STDIN there :?.
manilx
Posts: 124
Joined: Mon Dec 07, 2020 11:02 am

Re: problem while trying to upgrade to Bullseye following your blog post

Post by manilx »

2 pie4 upgraded.

1 without issues
2nd booted into "web" login. Had to go to dietpi-config autostart and change this.
X86 server to go...
manilx
Posts: 124
Joined: Mon Dec 07, 2020 11:02 am

Re: problem while trying to upgrade to Bullseye following your blog post

Post by manilx »

EDIT:

one one I got notification that updates were avaialble. After running the usual there is one which is not updated.....

apt update && apt full-upgrade
Hit:1 http://raspbian.raspberrypi.org/raspbian bullseye InRelease
Hit:2 http://download.zerotier.com/debian/bullseye bullseye InRelease
Hit:3 https://archive.raspberrypi.org/debian bullseye InRelease
Ign:4 https://download.webmin.com/download/repository sarge InRelease
Hit:6 https://download.webmin.com/download/repository sarge Release
Hit:5 https://dl.ubnt.com/unifi/debian stable InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
gcc-8-base
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

What is missing?
manilx
Posts: 124
Joined: Mon Dec 07, 2020 11:02 am

Re: problem while trying to upgrade to Bullseye following your blog post

Post by manilx »

Bummer:

On both I can no longer VNC into them.....

Run dietpi-software reinstall 23 28 but didn't help
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: problem while trying to upgrade to Bullseye following your blog post

Post by Joulinar »

You are running TigerVNC?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
manilx
Posts: 124
Joined: Mon Dec 07, 2020 11:02 am

Re: problem while trying to upgrade to Bullseye following your blog post

Post by manilx »

Joulinar wrote: Sun Aug 29, 2021 8:37 pm You are running TigerVNC?
Yes.
manilx
Posts: 124
Joined: Mon Dec 07, 2020 11:02 am

Re: problem while trying to upgrade to Bullseye following your blog post

Post by manilx »

Uninstalled TigerVNC and LXDE and then reinstalled.

Still no go....
Post Reply