Transmission error

Having issues with your DietPi installation or found a bug? Post it here.
User avatar
Joulinar
Posts: 5090
Joined: Sat Nov 16, 2019 12:49 am

Re: Transmission error

Post by Joulinar »

You could try adding your local client IP to rpc-whitelist. For doing this, you would need to stop Transmission first, perform the change and start Transmission afterwards. It's important to have Transmission stopped while doing the change. But I would wonder if this has any effect as whitelist-enabled is not active.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
trendy
Posts: 340
Joined: Tue Feb 25, 2020 2:54 pm

Re: Transmission error

Post by trendy »

There seem to be some lines missing. Please post the whole file, redacting the password.
cat /etc/transmission-daemon/settings.json
jhmc93
Posts: 12
Joined: Mon Jul 05, 2021 2:59 am

Re: Transmission error

Post by jhmc93 »

trendy wrote: Thu Jul 15, 2021 10:12 am There seem to be some lines missing. Please post the whole file, redacting the password.
cat /etc/transmission-daemon/settings.json
Here you go:

Code: Select all

"umask": 7,
    "message-level": 0,
    "rpc-whitelist-enabled": false,
    "trash-original-torrent-files": true,
    "ratio-limit-enabled": true,
    "ratio-limit": 1.1,
    "idle-seeding-limit-enabled": true,
    "idle-seeding-limit": 1,
    "upload-slots-per-torrent": 5,
    "peer-limit-global": 40,
    "download-queue-size": 3,
    "cache-size-mb": 788,
    "blocklist-enabled": 0, 
    "download-dir": "/mnt/dietpi_userdata/downloads",
    "download-limit": 100, 
    "download-limit-enabled": 0, 
    "encryption": 2,
    "max-peers-global": 200, 
    "peer-port": 51413, 
    "pex-enabled": 1, 
    "port-forwarding-enabled": true,
    "rpc-authentication-required": 1, 
    "rpc-port": 9091, 
    "rpc-username": "root",
    "rpc-whitelist": "127.0.0.1", 
    "upload-limit": 100, 
    "upload-limit-enabled": 0
User avatar
trendy
Posts: 340
Joined: Tue Feb 25, 2020 2:54 pm

Re: Transmission error

Post by trendy »

You have some weird values here:
rpc-authentication-required is boolean, not integer. Same for pex-enabled.
Maybe the default configuration file is overridden by environmental variables such as TRANSMISSION_HOME.
Also rpc-host-whitelist-enabled is missing and by default is true.
Maybe the quickest way to fix it is to set the IPs in rpc-host-whitelist and restart the service.
jhmc93
Posts: 12
Joined: Mon Jul 05, 2021 2:59 am

Re: Transmission error

Post by jhmc93 »

trendy wrote: Thu Jul 15, 2021 3:56 pm You have some weird values here:
rpc-authentication-required is boolean, not integer. Same for pex-enabled.
Maybe the default configuration file is overridden by environmental variables such as TRANSMISSION_HOME.
Also rpc-host-whitelist-enabled is missing and by default is true.
Maybe the quickest way to fix it is to set the IPs in rpc-host-whitelist and restart the service.
How would I do that?, I’m still quite new to Linux
User avatar
Joulinar
Posts: 5090
Joined: Sat Nov 16, 2019 12:49 am

Re: Transmission error

Post by Joulinar »

or remove transmission and perform a new installation to get correct config file. Might be fastest.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply