Changed to IPv6 / DS-Lite and need help

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
nilsacht
Posts: 24
Joined: Mon Jan 18, 2021 9:33 am

Changed to IPv6 / DS-Lite and need help

Post by nilsacht »

Hello there,

I changed from a DSL (IPv4) to a DS-Lite (IPv6) internet provider. Now I need some help to get my services back to work.

I use Nextcloud, Pi-VPN with Wireguard and letsencrypt on my dietpi. I used a paid NOIP.com hostname (example.com) to access my old setup and it worked fine. Now I strungle with DS LIte and IPv6.

Please can someone explain to me how i get this all back to work?

Thanks
Nils
User avatar
trendy
Posts: 314
Joined: Tue Feb 25, 2020 2:54 pm

Re: Changed to IPv6 / DS-Lite and need help

Post by trendy »

If you have a prefix delegated to your lan, then the lan hosts should have a public routable IPv6 address, so you can access the devices internally directly, as long as you allow it on the router firewall.
You can no longer access the lan devices over IPv4, as the v4 traffic is getting encapsulated and NATed with CGNAT from your provider.
nilsacht
Posts: 24
Joined: Mon Jan 18, 2021 9:33 am

Re: Changed to IPv6 / DS-Lite and need help

Post by nilsacht »

Ok thanks. But is there a way to get it work again? Nope.com give me the option to use a AAAA hostname.

And I thought if I have ipv6 portmapping to my pi in my router activated and the address added in the loop settings this should work.

But it seems like it dose not work this way.
nilsacht
Posts: 24
Joined: Mon Jan 18, 2021 9:33 am

Re: Changed to IPv6 / DS-Lite and need help

Post by nilsacht »

So I managed to get something to work.
Screenshot_20210606-080037.png
Screenshot_20210606-080024.png
But the connection don't work. Over hostname and Ipv6 address. It seams to load endlessly.

I changed the

Code: Select all

/etc/lighttpd/conf-enabled/50-dietpi-https.conf
so that it says

Code: Select all

$SERVER["socket"] == "[::]:443" {
.

What can I do next?
nilsacht
Posts: 24
Joined: Mon Jan 18, 2021 9:33 am

Re: Changed to IPv6 / DS-Lite and need help

Post by nilsacht »

I verified that my domain "example.com" is working. Only my nextcloud instand under example.com/nextcloud does not work.
nilsacht
Posts: 24
Joined: Mon Jan 18, 2021 9:33 am

Re: Changed to IPv6 / DS-Lite and need help

Post by nilsacht »

I am sorry but I am lost. I tried everything I found online and nothing worked.

All checks looked fine. But I can not access my Nextcloud over my AAAA Hostname from NOIP.com. I don't want so switch to an other service with cost me some money for 10% of my capacity.

Is there realy no way to get this working?
User avatar
trendy
Posts: 314
Joined: Tue Feb 25, 2020 2:54 pm

Re: Changed to IPv6 / DS-Lite and need help

Post by trendy »

nilsacht wrote: Sun Jun 06, 2021 9:39 am I verified that my domain "example.com" is working. Only my nextcloud instand under example.com/nextcloud does not work.
If the main domain is working, but the subdomain is not, I would check the configuration file of the nextcloud, like you did with /etc/lighttpd/conf-enabled/50-dietpi-https.conf. Unfortunately I don't have nextcloud, so I cannot help more.
User avatar
Joulinar
Posts: 4823
Joined: Sat Nov 16, 2019 12:49 am

Re: Changed to IPv6 / DS-Lite and need help

Post by Joulinar »

by default NextCloud is configured via sub path and not sub domain :)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3023
Joined: Sat Nov 18, 2017 6:21 pm

Re: Changed to IPv6 / DS-Lite and need help

Post by MichaIng »

Does it work to access the domain without /nextcloud path element to access the Lighttpd example index page?
Post Reply