justboom digi zero and Pi Zero W not working Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
foxy82
Posts: 3
Joined: Fri Jun 04, 2021 9:21 am

justboom digi zero and Pi Zero W not working

Post by foxy82 »

Hi,

I've just started using Diet Pi and I'm trying to get version 7.2 working with my Justboom digi zero DAC.

I set the sound card to justboom-digi in the config and rebooted. However when I try to test it I get this:

Code: Select all

dietpi@DietPi:~$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
dietpi@DietPi:~$ speaker-test

speaker-test 1.1.8

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Playback open error: -13,Permission denied
dietpi@DietPi:~$ sudo speaker-test

speaker-test 1.1.8

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Channels count (1) not available for playbacks: Invalid argument
Setting of hwparams failed: Invalid argument
dietpi@DietPi:~$
I installed Rasbian Jessie Lite and after an upgrade/dist-upgrade the DAC worked - so I think it is something in Diet Pi and not the card.

Is anyone able to help me?
User avatar
Joulinar
Posts: 4783
Joined: Sat Nov 16, 2019 12:49 am

Re: justboom digi zero and Pi Zero W not working

Post by Joulinar »

@MichaIng
You are the sound expert. Maybe you can have a look
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 2987
Joined: Sat Nov 18, 2017 6:21 pm

Re: justboom digi zero and Pi Zero W not working

Post by MichaIng »

Rasbian Jessie Lite
Where did you get a Raspbian Jessie image from? That should not be offered anywhere for years ;).

Please try to enable the automatic conversions plugin:
  • Run dietpi-config
  • Select Audio Options
  • Select Auto-conversion so that it states [On]
No reboot required, simply run again the speaker-test. To allow playing audio with the dietpi user (without sudo):

Code: Select all

usermod -aG audio dietpi
User avatar
Joulinar
Posts: 4783
Joined: Sat Nov 16, 2019 12:49 am

Re: justboom digi zero and Pi Zero W not working

Post by Joulinar »

Rasbian Jessie Lite
My hope is/was that this was a typo ;)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
foxy82
Posts: 3
Joined: Fri Jun 04, 2021 9:21 am

Re: justboom digi zero and Pi Zero W not working

Post by foxy82 »

Sorry yeah was raspios buster! I was trying so many images and tearing my hair out yesterday until I found it was the DAC wasn't quite seated correctly!

So before the reply I installed snapclient and that was working.

After the instructinos above the speaker_test works as well.

Thanks for your help - as @Joulinar has seen i've submitted a PR to get snapclient added to the software repo.
Post Reply