Hyper-V image fails to update Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
kazgor
Posts: 34
Joined: Sun Dec 17, 2017 10:18 pm

Hyper-V image fails to update

Post by kazgor »

Hello,

I was running the Hyper-V image 7.1.2 but when it offered to upgrade to 7.2.3 it was failing when it was getting the package list.

Give an error along the lines of

Code: Select all

[ INFO ] DietPi-Update | APT update, please wait...
Hit:1 https://deb.debian.org/debian buster InRelease
Get:2 https://deb.debian.org/debian buster-updates InRelease [51.9 kB]
Get:3 https://deb.debian.org/debian-security buster/updates InRelease [65.4 kB]
Get:4 https://deb.debian.org/debian buster-backports InRelease [46.7 kB]
Get:5 https://deb.debian.org/debian-security buster/updates/main amd64 Packages                                                          [291 kB]
Ign:6 https://download.webmin.com/download/repository sarge InRelease
Hit:7 https://download.webmin.com/download/repository sarge Release
Fetched 455 kB in 1s (422 kB/s)
Reading package lists...
E: lzma_read: Read error (10)
E: The package lists or status file could not be parsed or opened.
[FAILED] DietPi-Update | APT update
Did a quick search for LMZA READ error and the following worked for me.

In the updater, drop to a subshell then delete the contents of this folder

Code: Select all

/var/lib/apt/lists/
now Exit back to the Updater and hit RETRY and it then installed successfully
User avatar
Joulinar
Posts: 4783
Joined: Sat Nov 16, 2019 12:49 am

Re: Hyper-V image fails to update

Post by Joulinar »

Hi,

As well following should work

Code: Select all

/boot/dietpi/func/dietpi-set_software apt-cache clean
apt update
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply