nextcloud .ocdata error

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
linuxrules
Posts: 3
Joined: Sun May 23, 2021 10:36 pm
Contact:

nextcloud .ocdata error

Post by linuxrules »

I've place this line in this folder of php /etc/php/7.3/fpm/php.ini / open_basedir = /var/www/nextcloud/:/dev/urandom
I've left the default data directory where dietpi set-up data directory /mnt/dietpi_userdata/nextcloud_data. Below is the full line of the error message. Even though the file is there and the folders do have www-data:www-data

Your data directory is invalid Ensure there is a file called ".ocdata" in the root of the data directory. Cannot create "data" directory This can usually be fixed by giving the webserver write access to the root directory. See https://docs.nextcloud.com/server/21/go ... ermissions

What I've was doing before this error is to optimize the speed of the nextcloud with the extra php programs.
I've tried to read as much as what I can on nextcloud site with this error, no real concise help.

Could someone please help with this problem, even though I could uninstall and re-install to repair.
User avatar
Joulinar
Posts: 4783
Joined: Sat Nov 16, 2019 12:49 am

Re: nextcloud .ocdata error

Post by Joulinar »

Did you tried to revert the change you have done?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
linuxrules
Posts: 3
Joined: Sun May 23, 2021 10:36 pm
Contact:

Re: nextcloud .ocdata error

Post by linuxrules »

Yes, I removed the PHP line, still didn't go past the error. I did install the extra optimisation in nextcloud overview.
User avatar
Joulinar
Posts: 4783
Joined: Sat Nov 16, 2019 12:49 am

Re: nextcloud .ocdata error

Post by Joulinar »

can you tell me exactly what you have done? Because I would like to replicate the issue.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
linuxrules
Posts: 3
Joined: Sun May 23, 2021 10:36 pm
Contact:

Re: nextcloud .ocdata error

Post by linuxrules »

Ok it is working. Now it's showing this message under Overview
There are some warnings regarding your setup.

The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗.

Module php-imagick in this instance has no SVG support. For better compatibility it is recommended to install it.
User avatar
Joulinar
Posts: 4783
Joined: Sat Nov 16, 2019 12:49 am

Re: nextcloud .ocdata error

Post by Joulinar »

usually these messages can be ignored.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply