Cannot install Emby server on Odroid C1

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
mahenkpatel
Posts: 3
Joined: Tue Nov 29, 2016 4:05 pm

Cannot install Emby server on Odroid C1

Post by mahenkpatel »

Hi,

Tried installing Emby server but at the end getting below error and it stops

Code: Select all

The following packages have unmet dependencies:
 emby-server : Depends: libembysqlite3-0 but it is not installable
               Depends: embymagick but it is not installable
E: Unable to correct problems, you have held broken packages.
I tried adding every mono and emby related repo I could find in Dietpi's github and forum page but still getting this error. any help will is appreciated.

Thanks
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Cannot install Emby server on Odroid C1

Post by Fourdee »

Hi,

Thanks for the report. I'll take a look.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Cannot install Emby server on Odroid C1

Post by Fourdee »

Yep, replicated and confirmed. I've created a ticket here: https://github.com/Fourdee/DietPi/issues/619.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
mahenkpatel
Posts: 3
Joined: Tue Nov 29, 2016 4:05 pm

Re: Cannot install Emby server on Odroid C1

Post by mahenkpatel »

Thanks for the quick reply.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Cannot install Emby server on Odroid C1

Post by Fourdee »

mahenkpatel wrote:Thanks for the quick reply.
Long story short, looks like the OpenSuse repo that we use for installation, is missing ARMv7 packages for the new dependencies. This is out of our hands, so will try and get a response from Emby/OpenSuse.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Cannot install Emby server on Odroid C1

Post by Fourdee »

This will be fixed in the next DietPi update (v139): https://github.com/Fourdee/DietPi/issues/619.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply