IPv6 Settings Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
Niwre
Posts: 44
Joined: Tue Apr 09, 2019 1:26 pm

IPv6 Settings

Post by Niwre »

Hi,
I entered my IPv6 settings manually in the file /etc/network/network, which works fine. Unfortunately, the error message "ICMPv6: RA: ndisc_router_discovery failed to add default route" is now regularly in the logfile. If I remove the gateway from the file, the error message is gone. Can I disable this error message in logfile?
Regards
Niwre
User avatar
MichaIng
Site Admin
Posts: 2987
Joined: Sat Nov 18, 2017 6:21 pm

Re: IPv6 Settings

Post by MichaIng »

Can you show how you added the IPv6 address to /etc/network/interface (you meant I guess?)? It seems there is a conflict with the default IPv6 route which you should resolve instead of muting the error messages (which is not possible on per-message basis but only for all error messages).

Usually it is not required at all to define IPv6 interfaces, or at least skip the gateway entry if you require a specific IPv6 address. By default all interfaces will self-assign an IPv6 address via SLAAC auto-configuration and use the gateway based on router advertisements. That last steps seems to fail now, probably as you defined a default gateway manually?

To check the current IPv6 routes: ip -6 r
Niwre
Posts: 44
Joined: Tue Apr 09, 2019 1:26 pm

Re: IPv6 Settings

Post by Niwre »

@MichaIng
Thank you for the explanation, I wasn't aware of that. I have removed the gateway and have it assigned via SLAAC. The gateway and the route are the same, but the error message is gone. Thank you for your help.
Post Reply