Plex issues with mountingpoint

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Denny
Posts: 2
Joined: Sun Nov 27, 2016 4:19 pm

Plex issues with mountingpoint

Post by Denny »

Hello.

First of all: thanks for dietpi... It's a really great OS.

I have an Problem with my plexmediaserver. I have 3 USB Hard Disks and mounted with the internel setup by uuid in usb_2, usb_3 and usb_4.

Now when i unplugged any Device i can't open these directory where it is mounted. I think the plexmediaserver can't handle this because he is searching this directory and can't open this. Then when iam open plex on my TV he don't open this and i get an error.

Is it possible to Make a change that ist can open these folder when no hard drive is detectet?
Or can i change the mounting point into /media?

I has testet it with editing the /etc/fstab, and mounted to /media and it works. But then ist became an error from the internal disk Manager.

Thanks for answer and sorry for my bad english.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Plex issues with mountingpoint

Post by Fourdee »

Hi Denny,

I believe the issue is due to the x-systemd.automount entry in fstab. We use this to allow for SystemD automatic detection and mounting of the drives as they come available.
The downside is, if the drive is unplugged, after its been mounted previously, any program that tries to access the mount location will cause a hang with no response, even ls -lha /mnt/usb_4. Unfortunately, this is a SystemD issue with x-systemd.automount.

However, as a workaround, try removing the SystemD auto mount options in /etc/fstab (the drives will still be mounted at boot, if they are available), remove the following from all /mnt/usb_x entries/lines:

Code: Select all

,x-systemd.automount
Example line after the change:

Code: Select all

/dev/sde1       /mnt/usb_5      auto     defaults,noatime,nofail  0 0
Reload systemD with:

Code: Select all

systemctl daemon-reload
Then reboot system.

Just bear in mind, if the drive is unplugged when powered on (bad idea, unless you umount the drive 1st), you will need to manually re-mount the drive with:

Code: Select all

mount -a
Also, if not already, make sure your using UUID's when using multiple drives to ensure same mount target locations each time.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Denny
Posts: 2
Joined: Sun Nov 27, 2016 4:19 pm

Re: Plex issues with mountingpoint

Post by Denny »

Thank you so much Fourdee.

I removed the x-systemd.automount in fstab and it works very well. 8-)
Post Reply