Cannot boot - LD_LIBRARY_PATH issue Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
mckart
Posts: 5
Joined: Sun Apr 04, 2021 6:49 pm

Cannot boot - LD_LIBRARY_PATH issue

Post by mckart »

Hello,
My rpi had been working well for a while. I wanted to restart a service. I got "error while loading shared libraries: libuuid.so.1 cannot open shared object file" error. Then I tried $LD_LIBRARY_PATH command and it returned nothing. I tried to export but again $LD_LIBRARY_PATH but it returned nothing again. So I turned it off and on again. Now I am getting the same error during boot. What should I do? I think I have to set LD_LIBRARY_PATH variable but I dont know how.
User avatar
Joulinar
Posts: 4536
Joined: Sat Nov 16, 2019 12:49 am

Re: Cannot boot - LD_LIBRARY_PATH issue

Post by Joulinar »

Hi,

can you check installation status of libuuid1

Code: Select all

dpkg -l | grep libuuid1
If it is already installed, you could try to reinstall

Code: Select all

apt install --reinstall libuuid1
btw: what is the service you try running?

To set a variable you could do following
  1. Go to the home folder and edit .profile
  2. Place the following line at the end

    Code: Select all

    export LD_LIBRARY_PATH=<your path>
  3. Save and Exit.
  4. Execute this command

    Code: Select all

    sudo ldconfig
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
mckart
Posts: 5
Joined: Sun Apr 04, 2021 6:49 pm

Re: Cannot boot - LD_LIBRARY_PATH issue

Post by mckart »

Hello @Joulinar , thank you for fast response.
Unfortunatelly My rpi is not booting any more so I can’t enter ant command.
User avatar
Joulinar
Posts: 4536
Joined: Sat Nov 16, 2019 12:49 am

Re: Cannot boot - LD_LIBRARY_PATH issue

Post by Joulinar »

to bad, maybe something more broken on your device/SD card
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply