Odroid C2 - Sound drop with passthrough

Having issues with your DietPi installation, or, found a bug? Post it here.
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: Odroid C2 - Sound drop with passthrough

Post by Fourdee »

Mez882 wrote:HWith the settings you suggested, I do not have sound drops.
As soon as I enabled passthrough, keeping the same settings, I got the sound drops.
Hi Mez,

Thanks for the info.

If you can remember, was it the 8 Channel DTS-HD audio decoding: Off setting that prevented the sound drops, or, enable passthrough?

The only thing I can recommend is (if you haven't done already):
- Try another HDMI cable
- Update Firmware on your TV and/or try another TV.

Failing that, you may get more joy from the Odroid forums.
The Kodi package is maintained by Meveric, so would be worth searching his forum post and see if other users had similar issues: http://forum.odroid.com/viewtopic.php?f=138&t=19403
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Mez882
Posts: 24
Joined: Wed Nov 02, 2016 10:45 am

Re: Odroid C2 - Sound drop with passthrough

Post by Mez882 »

Hi Fourdee,

Thanks for all your efforts!
It is really only the enable passthrough:Off which prevents the sound drops.
I tried another HDMI cable and a different charger (but still not official one).
Note that the C2 is connected to a Denon receiver, not directly to the tv.
I guess I will just live without the passthrough. All the rest works perfectly!


Cheers,
Nicolas
gnopy
Posts: 13
Joined: Fri Feb 03, 2017 9:54 am

Re: Odroid C2 - Sound drop with passthrough

Post by gnopy »

Hello all.

Having the same issue (1 click every 10s), I was wondering if things were getting any progress about passthrough ?
Indeed, Kodi v17 is out now and "might" correct things, no ?

Cheers
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: Odroid C2 - Sound drop with passthrough

Post by Fourdee »

gnopy wrote:Hello all.

Having the same issue (1 click every 10s), I was wondering if things were getting any progress about passthrough ?
Indeed, Kodi v17 is out now and "might" correct things, no ?

Cheers
Hi,

Because the issue is visible at kernel level (dmesg):
http://dietpi.com/phpbb/viewtopic.php?f=11&t=889#p4038

I believe it may a bug in the kernel. But we wont know for sure, until our Odroid C2 image is updated to Stretch, which should bump Kodi up to v17 (pending Meveric's package changes), and could exclude kernel as the cause.

As i'am unable to replicate the broken sound at my end, i'd highly recommend posting this on the Odroid forums to hopefully get some suggestions/solutions:
http://forum.odroid.com/viewtopic.php?f=138&t=19403

Also, which board revisions are you guys running?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
gnopy
Posts: 13
Joined: Fri Feb 03, 2017 9:54 am

Re: Odroid C2 - Sound drop with passthrough

Post by gnopy »

Hi all,

it's been a while now that I scavenged the forums and every "tips & tricks" things to try to get this passthrough problem solved.
I tried the ALSA SINK solution. doesn't work for me. Seems to be a hack for the Odroid C1.
Tried with Hifi Plus board ... doesn't change the problem.
Tried going back to original Odroid linux ubuntu install (on the eMMc) (v16 i guess). Doesn't have the passthrough option and enabling it with commmand line crashed Kodi.
Tried with Kodi v17 (Krypton). nothing new.
Tried several different resolution setups : 4K,2K,HD and different frame rates. Because I thought that might be a synchronisation problem between video feed and sound. Nothing on that end either.
The only OS that worked out fine is LIBRELEC. But in this case I cannot install my cloud, ftp etc.

So, I'm running a little bit out of options and still be annoyed to get a sound stutter every 10 seconds on DTSHDs videos. (But the sound feels sooooo greater than in PCM ! Is it just me ?)

I'm still in v159 with ODROID C2 board, having everything working well.. except that audio thing.

I'm lazy to upgrade to Dietpi V6 since everything is going great now, with minimum IT annoyance.
I really feel Dietpi is the best solution for me with everything simplified and all.

My question now: is the problem solved in Dietpi V6 (v160+) and I'd better take a day to reinstall everything ?
Or drop it.

It's a shame because ODROID C2's board are great.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Odroid C2 - Sound drop with passthrough

Post by johnvick »

Why not try on a second SD card?

John
gnopy
Posts: 13
Joined: Fri Feb 03, 2017 9:54 am

Re: Odroid C2 - Sound drop with passthrough

Post by gnopy »

Sure that'll be the plan, of course.

The main question is : Does someone has the same problem of passthrough that may have be corrected with the upgrade ?
Post Reply