[SOLVED] Chrome Kiosk Mode | Disable web security headers (CORS) Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
ChriD
Posts: 4
Joined: Wed Jan 20, 2021 1:08 pm

[SOLVED] Chrome Kiosk Mode | Disable web security headers (CORS)

Post by ChriD »

Hi,

Is there a way to disable the security headers in chromium in kiosk mode?
On a "normal" chrome installation i'd use --disable-web-security, but that doesnt seem to work on chromium-browser

THX
Last edited by ChriD on Fri Apr 02, 2021 12:26 pm, edited 1 time in total.
ChriD
Posts: 4
Joined: Wed Jan 20, 2021 1:08 pm

Re: Chrome Kiosk Mode | Disable web security headers (CORS)

Post by ChriD »

Well, my fault... i have to add the --user-data-dir with a path, otherwise it wont work
User avatar
Joulinar
Posts: 4249
Joined: Sat Nov 16, 2019 12:49 am

Re: [SOLVED] Chrome Kiosk Mode | Disable web security headers (CORS)

Post by Joulinar »

thx for sharing your solution. :)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
novitibo
Posts: 116
Joined: Mon Feb 29, 2016 5:11 pm

Re: [SOLVED] Chrome Kiosk Mode | Disable web security headers (CORS)

Post by novitibo »

so... what is the correct url in Chrome Android app for Home Assistant then?

https://HA_IP:8123...?

tnx!
User avatar
Joulinar
Posts: 4249
Joined: Sat Nov 16, 2019 12:49 am

Re: [SOLVED] Chrome Kiosk Mode | Disable web security headers (CORS)

Post by Joulinar »

@novitibo
not sure how you question is related to this topic but HA Web UI is available via URL http://<your.IP>:8123 as stated on our online docs https://dietpi.com/docs/software/home_a ... -assistant
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply