How to suppress messages from a Wifi driver?

Having issues with your DietPi installation or found a bug? Post it here.
User avatar
MichaIng
Site Admin
Posts: 3106
Joined: Sat Nov 18, 2017 6:21 pm

Re: How to suppress messages from a Wifi driver?

Post by MichaIng »

Sorry for the missing reply, I just found this topic in my bookmarks. Have you been able to find a solution for the disconnects?

The first part of the log shows this every quite precisely 10 seconds:

Code: Select all

[ 2724.238493] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-LPS_CTRL_LEAVE
[ 2724.238528] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): FW LPS mode = 0, SmartPS=2, HW port id=0
[ 2724.963221] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[ 2724.963282] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): FW LPS mode = 2, SmartPS=2, HW port id=0
So like the adapter exists power save mode for less than a second, then enters it again directly. But then it enters a re-connection attempt loop which fails, until the end of the log. I also see "cfg80211_rtw_set_power_mgmt(wlan0) enabled:1, timeout:-1" in there, so at some level power management is enabled.

The first disconnect shows:

Code: Select all

[ 2794.587528] RTW: OnDeAuth(wlan0) - Start to Disconnect
[ 2794.587538] RTW: OnDeAuth(wlan0) reason=7, ta=a0:63:91:eb:9b:e8, ignore=0
[ 2794.587543] RTW: receive_disconnect
Checking those "reason" codes: https://community.cisco.com/t5/wireless ... -p/3148055
7 | Class 3 frame received from nonassociated station | NOT SUPPORTED
Then repeatedly:

Code: Select all

[ 3418.793872] RTW: OnDeAuth(wlan0) - Start to Disconnect
[ 3418.793926] RTW: OnDeAuth(wlan0) reason=15, ta=a0:63:91:eb:9b:e8, ignore=0
[ 3418.793960] RTW: receive_disconnect
15 | 4-Way Handshake timeout | NOT SUPPORTED
Which fits to those between the connection attempts:

Code: Select all

[ 3422.804213] RTW: link to Broadcom AP
[ 3422.804220] RTW: start auth
[ 3422.804233] RTW: issue_auth
[ 3423.096541] RTW: link_timer_hdl: auth timeout and try again
[ 3423.096625] RTW: issue_auth
[ 3423.396543] RTW: link_timer_hdl: auth timeout and try again
[ 3423.396611] RTW: issue_auth
[ 3423.696528] RTW: link_timer_hdl: auth timeout and try again
[ 3423.696575] RTW: issue_auth
[ 3423.996521] RTW: link_timer_hdl: auth timeout and try again
[ 3423.996563] RTW: issue_auth
[ 3424.296529] RTW: report_join_res(-1)
[ 3424.297788] RTW: =>mlmeext_joinbss_event_callback - End to Connection without 4-way
To me it looks like a driver or firmware issue, probably incompatibility with the Odroid C2 (?) kernel, that power management cannot be turned off and that it re-enters power save mode less than a second after exiting it.

The Makefile of the driver has some CONFIG_POWER_SAVING = y config, probably setting it to CONFIG_POWER_SAVING = n disables the power save feature for the driver module.
Post Reply