LXQt errors out after startx

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
locallocco
Posts: 6
Joined: Wed Mar 10, 2021 11:20 am

LXQt errors out after startx

Post by locallocco »

I installed LXQt via software install option in dietpi.txt. When install is done i try to start the desktop with

Code: Select all

startx 
command but it errors out with no screen found. I do have monitor connected to PI400 via HDMI. I used 64bit beta image version for raspberry. Here is xorg log:

Code: Select all

X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[  2376.244] Build Operating System: Linux 5.4.0-54-generic aarch64 Debian
[  2376.245] Current Operating System: Linux DietPi 5.10.5-v8+ #1392 SMP PREEMPT Sat Jan 9 18:56:30 GMT 2021 aarch64
[  2376.245] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 smsc95xx.macaddr=E4:5F:01:00:91:9B vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000  console=ttyS0,115200 console=tty1 root=PARTUUID=8f4dbd00-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet net.ifnames=0
[  2376.246] Build Date: 15 January 2021  02:03:57PM
[  2376.247] xorg-server 2:1.20.4-1+rpt2+deb10u3 (https://www.debian.org/support) 
[  2376.247] Current version of pixman: 0.36.0
[  2376.248] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  2376.248] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2376.250] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 10 08:18:06 2021
[  2376.251] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2376.251] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2376.251] (==) No Layout section.  Using the first Screen section.
[  2376.251] (==) No screen section available. Using defaults.
[  2376.251] (**) |-->Screen "Default Screen Section" (0)
[  2376.251] (**) |   |-->Monitor "<default monitor>"
[  2376.252] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[  2376.252] (**) Option "BlankTime" "0"
[  2376.252] (==) Automatically adding devices
[  2376.252] (==) Automatically enabling devices
[  2376.252] (==) Automatically adding GPU devices
[  2376.252] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  2376.252] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  2376.252] 	Entry deleted from font path.
[  2376.252] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  2376.252] 	Entry deleted from font path.
[  2376.252] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  2376.252] 	Entry deleted from font path.
[  2376.252] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[  2376.252] 	Entry deleted from font path.
[  2376.252] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  2376.252] 	Entry deleted from font path.
[  2376.252] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  2376.252] 	Entry deleted from font path.
[  2376.252] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	built-ins
[  2376.252] (==) ModulePath set to "/usr/lib/xorg/modules"
[  2376.252] (**) Extension "DPMS" is disabled
[  2376.252] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2376.252] (II) Loader magic: 0x55668c8e08
[  2376.252] (II) Module ABI versions:
[  2376.252] 	X.Org ANSI C Emulation: 0.4
[  2376.252] 	X.Org Video Driver: 24.0
[  2376.252] 	X.Org XInput driver : 24.1
[  2376.252] 	X.Org Server Extension : 10.0
[  2376.253] (++) using VT number 1

[  2376.254] (EE) systemd-logind: failed to get session: PID 17843 does not belong to any known session
[  2376.255] (II) no primary bus or device found
[  2376.255] (II) LoadModule: "glx"
[  2376.255] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2376.257] (II) Module glx: vendor="X.Org Foundation"
[  2376.257] 	compiled for 1.20.4, module version = 1.0.0
[  2376.257] 	ABI class: X.Org Server Extension, version 10.0
[  2376.257] (==) Matched modesetting as autoconfigured driver 0
[  2376.257] (==) Matched fbdev as autoconfigured driver 1
[  2376.257] (==) Assigned the driver to the xf86ConfigLayout
[  2376.257] (II) LoadModule: "modesetting"
[  2376.258] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  2376.258] (II) Module modesetting: vendor="X.Org Foundation"
[  2376.258] 	compiled for 1.20.4, module version = 1.20.4
[  2376.258] 	Module class: X.Org Video Driver
[  2376.258] 	ABI class: X.Org Video Driver, version 24.0
[  2376.258] (II) LoadModule: "fbdev"
[  2376.258] (WW) Warning, couldn't open module fbdev
[  2376.258] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  2376.258] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  2376.258] (WW) Falling back to old probe method for modesetting
[  2376.258] (EE) open /dev/dri/card0: No such file or directory
[  2376.258] (WW) Falling back to old probe method for modesetting
[  2376.258] (EE) open /dev/dri/card0: No such file or directory
[  2376.258] (EE) No devices detected.
[  2376.258] (EE) 
Fatal server error:
[  2376.259] (EE) no screens found(EE) 
[  2376.259] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  2376.259] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  2376.259] (EE) 
[  2376.262] (EE) Server terminated with error (1). Closing log file.[code]
[/code]


also it is strange that

Code: Select all

lspci
only shows PCI Bridge and USB controller - nothing related to display
locallocco
Posts: 6
Joined: Wed Mar 10, 2021 11:20 am

Re: LXQt errors out after startx

Post by locallocco »

same issue with 32bit rasberry pi img
User avatar
Joulinar
Posts: 5087
Joined: Sat Nov 16, 2019 12:49 am

Re: LXQt errors out after startx

Post by Joulinar »

Hi,

this is a known issue https://github.com/MichaIng/DietPi/issues/4175

A quick fix could be this one

Code: Select all

/boot/dietpi/func/dietpi-set_hardware rpi-opengl vc4-kms-v3d-pi4
reboot
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
locallocco
Posts: 6
Joined: Wed Mar 10, 2021 11:20 am

Re: LXQt errors out after startx

Post by locallocco »

Joulinar wrote: Wed Mar 10, 2021 5:05 pm Hi,

this is a known issue https://github.com/MichaIng/DietPi/issues/4175

A quick fix could be this one

Code: Select all

/boot/dietpi/func/dietpi-set_hardware rpi-opengl vc4-kms-v3d-pi4
reboot

thanks! this helped --> adding dev branch to dietpi.txt solves the problem (or follow the link above for manual solution)
User avatar
Joulinar
Posts: 5087
Joined: Sat Nov 16, 2019 12:49 am

Re: LXQt errors out after startx

Post by Joulinar »

pls keep in mind dev branch might contain some issues and is not fully tested as it is still in development. ;)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply