pie 4 hangs at empty screen Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

pie 4 hangs at empty screen

Post by manilx »

Hi

installed a new pie 4. All went well. Installed some basic apps.
Then I changed eth0 settings (static) and upon reboot I get a blinking cursor instead of the login prompt at the console (hdmi)
The ip settings were applied and I can ssh into it and get the console.
But the physical console stops at the blinking cursor.

Changing back to dhcp doesn't change this.

This is my 2nd pie and the first one didn't show this issues (Installed under dietpie 6).

Any ideas?
Last edited by manilx on Mon Mar 08, 2021 6:58 pm, edited 1 time in total.
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: pie 4 hangs at empty screen

Post by manilx »

It stops after "...waiting for valid network connection...."
themagicm
Posts: 12
Joined: Sat Apr 18, 2020 6:05 am

Re: pie 4 hangs at empty screen

Post by themagicm »

did you change anything in config.txt?
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: pie 4 hangs at empty screen

Post by manilx »

Nope.
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: pie 4 hangs at empty screen

Post by manilx »

I have now installed from fresh image 3 times.

I've nailed it down to LXDE. Once I install this and reboot I get the blinking cursor in pysical console....
When I ssh into it and uninstall LXDE it boots alright again.


This is what I have in config.txt:

Code: Select all

# Docs: https://www.raspberrypi.org/documentation/configuration/config-txt/

#-------Display---------
# If you get no picture, set the following to "1" to apply most compatible HDMI settings.
#hdmi_safe=1

# Uncomment to adjust the HDMI signal strength if you have interferences, blanking, or no display.
# - Values from "0" to "11" are allowed, use values above "7" only if required, e.g. with very long HDMI cable.
# - Default on first RPi1 A/B is "2", else "5", on RPi4 this setting is ignored.
#config_hdmi_boost=5

# Uncomment if HDMI display is not detected and composite is being outputted.
#hdmi_force_hotplug=1

# Uncomment to disable HDMI even if plugged, e.g. to force composite output.
#hdmi_ignore_hotplug=1

# Uncomment to force a console size. By default it will be display's size minus overscan.
#framebuffer_width=1280
#framebuffer_height=720

# Uncomment to enable SDTV/composite output on RPi4. This has no effect on previous RPi models.
#enable_tvout=1
# SDTV mode
#sdtv_mode=0

# Uncomment to force a specific HDMI mode (this will force VGA).
#hdmi_group=1
#hdmi_mode=1

# Uncomment to force an HDMI mode rather than DVI. This can make audio work in DMT (computer monitor) modes.
#hdmi_drive=2

# Set "hdmi_blanking=1" to allow the display going into standby after 10 minutes without input.
# With default value "0", the display shows a blank screen instead, but will not go into standby.
# NB: With "1" some applications (e.g. Kodi, OMXPlayer) cannot prevent display standby due to missing DPMS signal.
#hdmi_blanking=1

# Set to "1" if your display has a black border of unused pixels visible.
disable_overscan=1

# Uncomment the following to adjust overscan. Use positive numbers if console goes off screen, and negative if there is too much border.
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# Rotation
display_hdmi_rotate=0
lcd_rotate=0

#-------RPi camera module-------
#start_x=1
#disable_camera_led=1

#-------GPU memory splits-------
gpu_mem_256=64
gpu_mem_512=64
gpu_mem_1024=64

#-------Boot splash screen------
disable_splash=1

#-------Onboard sound----------
dtparam=audio=on

#-------I2C-------------
dtparam=i2c_arm=off
dtparam=i2c1=off
#dtparam=i2c_arm_baudrate=100000

#-------SPI-------------
dtparam=spi=off

#-------Serial/UART-----
# NB: Enabled for 1st run only. If you want to keep this setting, please set CONFIG_SERIAL_CONSOLE_ENABLE=1 in dietpi.txt before 1st boot.
#core_freq=500
enable_uart=1

#-------Overclock-------
temp_limit=75
initial_turbo=20

#over_voltage=0
arm_freq=1600
#core_freq=500

#over_voltage_min=0
#arm_freq_min=300
#core_freq_min=250
#sdram_freq_min=400
dtoverlay=disable-wifi
User avatar
Joulinar
Posts: 4783
Joined: Sat Nov 16, 2019 12:49 am

Re: pie 4 hangs at empty screen

Post by Joulinar »

did you have set LXDE to autostart? What image are you using? 64bit or 32bit?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: pie 4 hangs at empty screen

Post by manilx »

Hi

No it was not set to auto start. It should start to the normal login prompt.
I used the 32 bit image.

I have now a virgin installed and running installation, with some apps installed but before LXDE.
I have made a dietpi-backup to be easily revertable.

So if you need any config files before LXDE install and after another installation let me know.
User avatar
Joulinar
Posts: 4783
Joined: Sat Nov 16, 2019 12:49 am

Re: pie 4 hangs at empty screen

Post by Joulinar »

ok, I'm able to replicate. Let me check with developer.

If you don't mind, can you try following once LXDE was installed

Code: Select all

/boot/dietpi/func/dietpi-set_hardware rpi-opengl vc4-kms-v3d-pi4
reboot
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: pie 4 hangs at empty screen

Post by manilx »

Sorry I don’t quite understand.
Do you mean to reinstall and then run this command?
User avatar
Joulinar
Posts: 4783
Joined: Sat Nov 16, 2019 12:49 am

Re: pie 4 hangs at empty screen

Post by Joulinar »

if you find time, install LXDE again and execute the command followed by a reboot.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply