update error

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
forevergreen
Posts: 20
Joined: Tue Feb 02, 2021 9:01 am

update error

Post by forevergreen »

So I did the upgrade, middle of the update I get this with error:
Downloading update archive
- Command: curl -sSfLO https://github.com/MichaIng/DietPi/arch ... ter.tar.gz

I got to a pink screen that told me if I wanted to rerun the command and I said yes, then it worked. Just wondering if all is good and why did I get an error? I know nothing about Linux.

Also, much thanks for inserting that Microsoft tracker prompt to erase. I thought I deleted it but maybe I didn't do it right.

EDIT: I have another Pi that I logged into but didn't get the update to 3.5 prompt from 6.34.4 , just wondering why? I did run DietPi-Update anyway and it worked.

EDIT2: Looks like I somehow updated to v7.0.2 which I believe is beta. I don't want to be on beta, I dont want trouble I want stability. What should I do?
User avatar
Joulinar
Posts: 5087
Joined: Sat Nov 16, 2019 12:49 am

Re: update error

Post by Joulinar »

Hi,

DietPi 7.0.2 is the new version and was officially released last night. There is nothing else to do from your side.

Let me answer your questions now:
So I did the upgrade, middle of the update I get this with error:
Downloading update archive
- Command: curl -sSfLO https://github.com/MichaIng/DietPi/arch ... ter.tar.gz

I got to a pink screen that told me if I wanted to rerun the command and I said yes, then it worked. Just wondering if all is good and why did I get an error? I know nothing about Linux.
unfortunately you did not copied the entire error message. Therefore we don't know what happen. I guess it was a temp connection issue.
EDIT: I have another Pi that I logged into but didn't get the update to 3.5 prompt from 6.34.4 , just wondering why? I did run DietPi-Update anyway and it worked.
The new version has been released last night and it could take a while before it is showing up on all devices
EDIT2: Looks like I somehow updated to v7.0.2 which I believe is beta. I don't want to be on beta, I dont want trouble I want stability. What should I do?
DietPi v7.0.2 is the official release and not a Beta
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
forevergreen
Posts: 20
Joined: Tue Feb 02, 2021 9:01 am

Re: update error

Post by forevergreen »

thanks for answer

1-When I logged to dietpi it had an announcement at top saying "please help test the v7 beta" so this is why

2-the prompt I got was there is a new update to 6.35 but after the update I got v7.0.2 so I thought I did something wrong along the way
User avatar
Joulinar
Posts: 5087
Joined: Sat Nov 16, 2019 12:49 am

Re: update error

Post by Joulinar »

6.35 was a small upgrade step needed to be able to go to v7 :D
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply