Killed my Lighttpd Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
GreenGentleman
Posts: 47
Joined: Mon Nov 09, 2020 4:10 pm

Re: Killed my Lighttpd

Post by GreenGentleman »

I removed everything with my domain in it, and now I'll wait until I can request another certificate. (I backed up the whole folder first, just in case! Sometimes, I'll learn from my mistakes 8) )

Thank you so much for the help so far!
User avatar
Joulinar
Posts: 4823
Joined: Sat Nov 16, 2019 12:49 am

Re: Killed my Lighttpd

Post by Joulinar »

Ok let's see if this will work now
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
GreenGentleman
Posts: 47
Joined: Mon Nov 09, 2020 4:10 pm

Re: Killed my Lighttpd

Post by GreenGentleman »

Code: Select all

[  OK  ] DietPi-LetsEncrypt | Lighttpd webserver detected
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate

IMPORTANT NOTES:
 - Congratulations! Your certificate and chain have been saved at:
   /etc/letsencrypt/live/MY_DOMAINt/fullchain.pem
   Your key file has been saved at:
   /etc/letsencrypt/live/MY_DOMAIN/privkey.pem
   Your cert will expire on 2021-06-05. To obtain a new or tweaked
   version of this certificate in the future, simply run certbot
   again. To non-interactively renew *all* of your certificates, run
   "certbot renew"
 - If you like Certbot, please consider supporting our work by:

   Donating to ISRG / Let's Encrypt:   https://letsencrypt.org/donate
   Donating to EFF:                    https://eff.org/donate-le

[  OK  ] DietPi-LetsEncrypt | Desired setting in /etc/lighttpd/lighttpd.conf was already set:   "mod_setenv",
Enabling dietpi-https: ok
Run "service lighttpd force-reload" to enable changes
Enabling dietpi-https_redirect: ok
Run "service lighttpd force-reload" to enable changes
already enabled
Run "service lighttpd force-reload" to enable changes

Press any key to continue...
I can't seem to connect, though. I'll restart my router (had to reenable ports) and the pi.
User avatar
Joulinar
Posts: 4823
Joined: Sat Nov 16, 2019 12:49 am

Re: Killed my Lighttpd

Post by Joulinar »

But certificate seems to be created
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
GreenGentleman
Posts: 47
Joined: Mon Nov 09, 2020 4:10 pm

Re: Killed my Lighttpd

Post by GreenGentleman »

Yeah, I had to press a button to let dietpi restart the services :D Everything is working as intended now.

Thank you so much for your help!
User avatar
Joulinar
Posts: 4823
Joined: Sat Nov 16, 2019 12:49 am

Re: Killed my Lighttpd

Post by Joulinar »

ok perfect, after long journey you are back online :D
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply