Switching onboard Wifi to usb dongle Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
dd667

Switching onboard Wifi to usb dongle

Post by dd667 »

Hello, as the title says, is there anyone who could help me switch the hardware used by wifi on my raspberry pi. I have DietPi installed and set as hotspot for my home network. The difference is that I just need a little bit more range so I bought the RAlink RT5572 to use with my Rpi. The default settings for DietPi is to use the wlan0 which is set as the onboard wifi module. I figured all it needs is to change certain settings in the respective files, ie. hostapd etc. The issue is that when I use command lsusb the device seems to be plugged in as it appears on the list

Code: Select all

root@DietPi:~# lsusb
Bus 001 Device 006: ID 1a2c:0b2a China Resource Semico Co., Ltd
Bus 001 Device 005: ID 045e:07b2 Microsoft Corp.
Bus 001 Device 004: ID 148f:5572 Ralink Technology, Corp. RT5572 Wireless Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
...everything seems fine I guess, but then I tried ifconfig. The list shows the wlan0 as suspected, on one hand I cannot determine which Wifi is being used, but the dongle has LED indicator when connection is made or data is being streamed. No activity on it what so ever.

Code: Select all

root@DietPi:~# ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:32:d3:0a
          inet addr:192.168.0.20  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::ba27:ebff:fe32:d30a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:348355 errors:0 dropped:0 overruns:0 frame:0
          TX packets:120019 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:242680629 (231.4 MiB)  TX bytes:26508753 (25.2 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:13 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:1764 (1.7 KiB)  TX bytes:1764 (1.7 KiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:67:86:5f
          inet addr:192.168.42.1  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::ba27:ebff:fe67:865f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:149942 errors:0 dropped:11 overruns:0 frame:0
          TX packets:169251 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:28556218 (27.2 MiB)  TX bytes:205452316 (195.9 MiB)

Is there a way to simply switch to the USB dongle so it covers more range or am I bound to use the onboard wifi module ? Also it looks like the device is recognized or not installed/active?
Thanks!
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: Switching onboard Wifi to usb dongle

Post by k-plan »

Hi,
dd667 wrote:...who could help me switch the hardware used by wifi on my raspberry pi.
if your device is a RPi3, you can update to DietPi v137 and disable Onboard WiFi from dietpi-config.

https://github.com/Fourdee/DietPi/issue ... -258697142

Image

https://github.com/Fourdee/DietPi/commi ... 508fc29dR6
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
Post Reply