WiringPi on Odroid Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
bruz
Posts: 10
Joined: Tue Feb 02, 2021 11:06 am

WiringPi on Odroid

Post by bruz »

Hi,

just tried to install WiringPi from "Software Optimized" (via DietPi-Software) on an Odroid N2, but this failed.

Checking the log and looking into the code of the WiringPi package (which is downloaded from https://github.com/hardkernel/wiringPi/ ... ter.tar.gz) pointed me to a missing folder '/usr/local/bin' (which is targeted to install the gpio binary, see wiringPi-master/gpio/Makefile).

Not sure, what actually the bug is (I guess in the mentioned Makefile of the WiringPi package there should be some check for the path or a differenciation depending on the distribution), but just manually creating the folder '/usr/local/bin' and reinstalling WiringPi through dientpi-software fixed the issue for me... Maybe this folder should be created in the DietPi image by default?
User avatar
Joulinar
Posts: 3688
Joined: Sat Nov 16, 2019 12:49 am

Re: WiringPi on Odroid

Post by Joulinar »

Hi,

many thanks for your message. Basically it's not an issue to add a check for for the availability of /usr/local/bin to our script. :)

RP up https://github.com/MichaIng/DietPi/pull/4079
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 2613
Joined: Sat Nov 18, 2017 6:21 pm

Re: WiringPi on Odroid

Post by MichaIng »

Many thanks for reporting. I remember a few other cases where /usr/local/ sub directories were missing, so good to not expect them to exist. PR merged to be released with DietPi v6.35. Changelog entry is here: https://github.com/MichaIng/DietPi/comm ... 90abfa2dbb
Post Reply