Problem with KODI "Version Check" and Autostart

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
oesel
Posts: 1
Joined: Sat Jan 30, 2021 9:21 am

Problem with KODI "Version Check" and Autostart

Post by oesel »

Hi together,

yesterday I have installed KODI on my raspberry and allowed autorun for this program.
KODI started successfully, but after a few seconds it shows the following message "Version Check: Using 18.7 stable while 18.9 is available. A new stable version of Kodi is available. Visit http://kodi.tv for more information."

There is an OK-button, but I can't click it.
The keyboard has no function (like the TAB-key to jump to the OK button) and the mouse didn't work, too.

Furthermore, as I have accepted autorun for KODI I cannot stop this process (like esc or F12 to jump into BIOS by a standard PC).

Can anybody help me, how I can reset the autorun function and how I can accept the "Version Check"-message or update KODI to the latest stable version.

Thanks a lot in advance.
User avatar
Joulinar
Posts: 3821
Joined: Sat Nov 16, 2019 12:49 am

Re: Problem with KODI "Version Check" and Autostart

Post by Joulinar »

Hi,

you could login to command line using SSH and open dietpi-config > 9 : AutoStart Options to remove Kodi from AutoStart. And Kodi 18.7 is the latest stable version on Raspberry OS.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
DarrenHill
Posts: 42
Joined: Wed May 08, 2019 3:00 pm

Re: Problem with KODI "Version Check" and Autostart

Post by DarrenHill »

And if you're just wanting Kodi (and not anything else) then maybe consider LibreElec or OSMC as alternatives.

Both are packaged versions of Kodi plus enough OS behind it to run it (and only it, at least in the case of LE - OSMC can support a bit more).
Post Reply