How to disable auto spin UP?

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
thanos
Posts: 1
Joined: Tue Jan 05, 2021 1:46 pm

How to disable auto spin UP?

Post by thanos »

I'm running latest dietpi on a Raspberry 2, running ownCloud.
External USB HD (Intenso), which I see spinning UP every ~10 mins or so, stays up ~1-2 mins, then spins down again. I have Idle Spindown set to 0 (Disabled), through dietpi-drive_manager.

So the problem is it spins UP more than I want it to. I don't use the ownCloud client often, and theoretically the drive should stay idle for hours on end.

Dietpi boots from a card, so the system is not located on the HD.

Any ideas what might be the issue?
User avatar
WarHawk
Posts: 774
Joined: Thu Jul 20, 2017 8:55 am

Re: How to disable auto spin UP?

Post by WarHawk »

Do you have the default ramlog #1 profile setup (if you didn't change it, it should be set that way) check in dietpi-software under Log System), and/or do you have a swap file on your external HD?

You could install iotop and see what is writing to your drive at random intervals


Then run

Code: Select all

iotop -o -b -d 10
to see what is actually reading/writing to the drive..., it will delay posting the output every 10 seconds...change the -d to something larger if you want to slow down the refresh times
Post Reply