Kodi freezes, then settings get lost every once in a while

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
tritrek
Posts: 3
Joined: Thu Dec 31, 2020 6:37 pm

Kodi freezes, then settings get lost every once in a while

Post by tritrek »

Hi,
am running DietPi on an Rpi2 and Kodi gets lost every once in a while. I'm watching a movie one night, switch my TV to "Kodi" the next day (via HDMI) and it's black, however DietPi is up and running (checked via SSH). Also, PiHole running beside it is working without any issues.
Sometimes a simple restart of Kodi is enough but sometimes all settings are lost in Kodi and have to set it up again from scratch and it's quite annoying.
Any suggestions? Thanks.
User avatar
Joulinar
Posts: 4823
Joined: Sat Nov 16, 2019 12:49 am

Re: Kodi freezes, then settings get lost every once in a while

Post by Joulinar »

Hi,

looks like something not functioning on Kodi. Probably you could check on a Kodi specialised board an what the issue could be and where to look into. Not sure if we have this deep Kodi knowledge on this board.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
DarrenHill
Posts: 42
Joined: Wed May 08, 2019 3:00 pm

Re: Kodi freezes, then settings get lost every once in a while

Post by DarrenHill »

How are you exiting Kodi?

When it is shutdown properly (via the quit option on the main menu) it will do various housekeeping bits and update databases and settings files.

If the shutdown is not done cleanly (either the process is killed or if some addon or script screws with it) then it can cause corruption issues. Your loss of settings is one such example of that, if the guisettings.xml file gets interrupted when it's being written to when Kodi is shutting down then on the next start-up it can no longer be read and Kodi will revert back to default settings.
Post Reply