Problems accessing TasmoAdmin Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
User avatar
Joulinar
Posts: 3822
Joined: Sat Nov 16, 2019 12:49 am

Re: Problems accessing TasmoAdmin

Post by Joulinar »

how does the config file looks like now

Code: Select all

cat /etc/lighttpd/lighttpd.conf
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

should i do another pihole -r for restoring an functional webserver?

//

Code: Select all

root@DietPi:~# cat /etc/lighttpd/lighttpd.conf

  "url-path-dotseg-remove"  => "enable",# recommended highly (unless breaks app)
 #"url-path-dotseg-reject"  => "enable",
 #"url-query-20-plus"       => "enable",# consistency in query string
)

index-file.names            = ( "index.php", "index.html" )
url.access-deny             = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/javascript", "text/css", "text/html", "text/plain" )

# default listening port for IPv6 falls back to the IPv4 port
include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.conf.pl"
include "/etc/lighttpd/conf-enabled/*.conf"

#server.compat-module-load   = "disable"
server.modules += (
        "mod_compress",
        "mod_dirlisting",
        "mod_staticfile",
)
root@DietPi:~# 
Last edited by UsAs on Thu Dec 31, 2020 12:06 am, edited 1 time in total.
User avatar
Joulinar
Posts: 3822
Joined: Sat Nov 16, 2019 12:49 am

Re: Problems accessing TasmoAdmin

Post by Joulinar »

no, pls share the information requested
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

done.

//

ah i see, config hasn't fully been pasted.

//

how do i edit the existing file?
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

edited the file, still not starting.

Code: Select all

root@DietPi:~# cat /etc/lighttpd/lighttpd.conf
server.modules = (
        "mod_indexfile",
        "mod_setenv",
        "mod_access",
        "mod_alias",
        "mod_redirect",
        "mod_accesslog",
)

server.document-root        = "/var/www"
server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
server.errorlog             = "/var/log/lighttpd/error.log"
server.pid-file             = "/var/run/lighttpd.pid"
server.username             = "www-data"
server.groupname            = "www-data"
server.port                 = 80
accesslog.filename          = "/var/log/lighttpd/access.log"

# strict parsing and normalization of URL for consistency and security
# https://redmine.lighttpd.net/projects/lighttpd/wiki/Server_http-parseoptsDetails
# (might need to explicitly set "url-path-2f-decode" = "disable"
#  if a specific application is encoding URLs inside url-path)
server.http-parseopts = (
  "header-strict"           => "enable",# default
  "host-strict"             => "enable",# default
  "host-normalize"          => "enable",# default
  "url-normalize-unreserved"=> "enable",# recommended highly
  "url-normalize-required"  => "enable",# recommended
  "url-ctrls-reject"        => "enable",# recommended
  "url-path-2f-decode"      => "enable",# recommended highly (unless breaks app)
 #"url-path-2f-reject"      => "enable",
  "url-path-dotseg-remove"  => "enable",# recommended highly (unless breaks app)
 #"url-path-dotseg-reject"  => "enable",
 #"url-query-20-plus"       => "enable",# consistency in query string
)

index-file.names            = ( "index.php", "index.html" )
url.access-deny             = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/javascript", "text/css", "text/html", "text/plain" )

# default listening port for IPv6 falls back to the IPv4 port
include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.conf.pl"
include "/etc/lighttpd/conf-enabled/*.conf"

#server.compat-module-load   = "disable"
server.modules += (
        "mod_compress",
        "mod_dirlisting",
        "mod_staticfile",
)
root@DietPi:~# 

Code: Select all

root@DietPi:~# cat /etc/lighttpd/lighttpd.conf
[C[C[C[C[C[C[C[C[C[C[C[C[C[C[Csystemctl status lighttpd.service
[0;1;31m●[0m lighttpd.service - Lighttpd Daemon
   Loaded: loaded (/lib/systemd/system/lighttpd.service; disabled; vendor preset: enabled)
   Active: [0;1;31mfailed[0m (Result: exit-code) since Wed 2020-12-30 22:47:37 GMT; 25min ago
  Process: 814 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf [0;1;31m(code=exited, status=255/EXCEPTION)[0m

Dez 30 22:47:37 DietPi systemd[1]: lighttpd.service: Service RestartSec=100ms expired, scheduling restart.
Dez 30 22:47:37 DietPi systemd[1]: lighttpd.service: Scheduled restart job, restart counter is at 5.
Dez 30 22:47:37 DietPi systemd[1]: Stopped Lighttpd Daemon.
Dez 30 22:47:37 DietPi systemd[1]: [0;1;39m[0;1;31m[0;1;39mlighttpd.service: Start request repeated too quickly.[0m
Dez 30 22:47:37 DietPi systemd[1]: [0;1;39m[0;1;31m[0;1;39mlighttpd.service: Failed with result 'exit-code'.[0m
Dez 30 22:47:37 DietPi systemd[1]: [0;1;31m[0;1;39m[0;1;31mFailed to start Lighttpd Daemon.[0m
root@DietPi:~# 
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

running again.

even tasmoadmin works now. much appreciate your help with a noobie like me. thank you very much!

Code: Select all

root@DietPi:~# systemctl restart lighttpd.service
root@DietPi:~# systemctl restart lighttpd.service[1Pstatus[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C
[0;1;32m●[0m lighttpd.service - Lighttpd Daemon
   Loaded: loaded (/lib/systemd/system/lighttpd.service; disabled; vendor preset: enabled)
   Active: [0;1;32mactive (running)[0m since Wed 2020-12-30 23:14:14 GMT; 1s ago
  Process: 2333 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf (code=exited, status=0/SUCCESS)
 Main PID: 2339 (lighttpd)
    Tasks: 1 (limit: 2182)
   CGroup: /system.slice/lighttpd.service
           └─2339 /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf

Dez 30 23:14:13 DietPi systemd[1]: Starting Lighttpd Daemon...
Dez 30 23:14:14 DietPi systemd[1]: Started Lighttpd Daemon.
root@DietPi:~# 
User avatar
Joulinar
Posts: 3822
Joined: Sat Nov 16, 2019 12:49 am

Re: Problems accessing TasmoAdmin

Post by Joulinar »

ok I guess some copy / past issues on creating the new file?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

i created a new config file. seems like copy & paste issue.

everything started with pihole -r.

again, many thanks for helping out with my problem, appreciate it!
User avatar
Joulinar
Posts: 3822
Joined: Sat Nov 16, 2019 12:49 am

Re: Problems accessing TasmoAdmin

Post by Joulinar »

be careful using pihole -r. It hast 2 option. One can damage your entire web server as PiHole assume being alone on the world and try to configure the web server alone for PiHole usage.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply