How prepare the transition/upgrade from Buster to next version? Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
mail2rst
Posts: 135
Joined: Fri Apr 13, 2018 4:53 pm

Re: How prepare the transition/upgrade from Buster to next version?

Post by mail2rst »

Adguard home web page give this error

Code: Select all

Error: control/version.json | Couldn't get version check json from https://static.adguard.com/adguardhome/release/version.json: *fmt.wrapError updater: HTTP GET https://static.adguard.com/adguardhome/release/version.json: Get "https://static.adguard.com/adguardhome/release/version.json": read udp 127.0.0.1:46223->127.0.0.1:5335: read: connection refused | 502
User avatar
MichaIng
Site Admin
Posts: 3106
Joined: Sat Nov 18, 2017 6:21 pm

Re: How prepare the transition/upgrade from Buster to next version?

Post by MichaIng »

Do the other devices user AdGuard Home for name resolution/ad blocking? Looks like it has an issue to contract the update server.

Does AdGuard Home use Unbound or another local resolver? I see a refused 127.0.0.1:5335 connection. In case check Unbound status:

Code: Select all

journalctl -u unbound
mail2rst
Posts: 135
Joined: Fri Apr 13, 2018 4:53 pm

Re: How prepare the transition/upgrade from Buster to next version?

Post by mail2rst »

both system show this fail display page.
Raspberry pi running. homeasssitant, valutwarden, mqtt broker, zigbee2mqtt, openssh
nuc running : plex, adguard, unbound, wireguard, openssh

unbound, homeasssistant, adguard are in trouble
valut warden lokks ok, adguard screen show error (may be unbound).

in dietpi-config networg adpter static & dns resolver cloudflare 1.1.1.1
Attachments
error.png
User avatar
Joulinar
Posts: 5149
Joined: Sat Nov 16, 2019 12:49 am

Re: How prepare the transition/upgrade from Buster to next version?

Post by Joulinar »

As you can see on your first screen print, there is an issue with Mosquitto as there is no Bullseye repository available yet. This we already discovered and a workaround is described on the link I posted above https://github.com/MichaIng/DietPi/issu ... -877590830

On the 2nd screen the issue is with the repository name for debian-security. On Bullseye it's called bullseye-security at the moment and not just bullseye. /etc/apt/sources.list you would need to adjust as follow

Code: Select all

sed -i 's|bullseye/updates|bullseye-security|' /etc/apt/sources.list
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
mail2rst
Posts: 135
Joined: Fri Apr 13, 2018 4:53 pm

Re: How prepare the transition/upgrade from Buster to next version?

Post by mail2rst »

Thanks @Joulinar & @MichaIng With your given hints, I am able to troubleshoot both my machines. I confirm that both my machine migrated to bullseye from buster. All my software works same way no change

Raspbeerry pi B2 > Homeasssistant, MQTT, zigbee2mqtt, valutwarden, openssh
NUC AMD64 > plex, adguard home , unbound 1.13, wireguard, openssh

Thanks for your hard work & expert advises every time.
User avatar
Joulinar
Posts: 5149
Joined: Sat Nov 16, 2019 12:49 am

Re: How prepare the transition/upgrade from Buster to next version?

Post by Joulinar »

thx for sharing. Don't forget to switch Mosquitto to Bullseye once they added the repository. You can watch the repo https://repo.mosquitto.org/debian/dists/
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply