Analogue audio output gone with v136/JustBoom [SOLVED] Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
fhals

Analogue audio output gone with v136/JustBoom [SOLVED]

Post by fhals »

Hi,

can't bring back my analogue audio since v136 with JustBoom included.
OrangePi PC using ympd as a player.

When I try to launch alsamixer, I get an "cannot open mixer: Invalid argument".
Used to work fine before.
When I enable the equalizer in dietpi-config, I can launch alsamixer from there but it doesn't keep my settings.
Anybody else who already found a workaround?

Thanks
Frans
Last edited by fhals on Tue Nov 08, 2016 10:04 pm, edited 2 times in total.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Analogue audio output gone with v136/JustBoom

Post by Fourdee »

Hi Frans,

Thanks for letting us know.

Is h3-analogue the selected soundcard in dietpi-config > audio options > soundcard ? (default is HDMI)
When I enable the equalizer in dietpi-config, I can launch alsamixer from there but it doesn't keep my settings.
Which user account are you logged in as?
Can you also please paste results of the following:

Code: Select all

ls -lha "$HOME"
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
fhals

Re: Analogue audio output gone with v136/JustBoom

Post by fhals »

yes, h3-analogue is the selected soundcard.
I'm logged in as root, ls output below.
Thank you for caring!

root@DietPi:~# ls -lha "$HOME"
total 88K
drwx------ 8 root root 4.0K Nov 6 21:33 .
drwxr-xr-x 23 root root 4.0K Sep 11 19:47 ..
-rw-r--r-- 1 root root 824 Nov 6 21:33 .alsaequal.bin
-rw------- 1 root root 8.2K Nov 8 11:45 .bash_history
-rw-r--r-- 1 root root 591 May 6 2016 .bashrc
drwxr-xr-x 6 root root 4.0K Sep 9 22:41 .cache
-rwxr-xr-x 1 root root 496 Sep 11 23:47 checkusb
drwx------ 9 root root 4.0K Sep 11 17:13 .config
drwx------ 3 root root 4.0K Sep 9 21:32 .dbus
drwxr-xr-x 2 root root 4.0K Sep 9 21:25 Desktop
-rwxr-xr-x 1 root root 192 Sep 11 15:46 .gtk-bookmarks
drwx------ 4 root root 4.0K Sep 9 22:41 .mozilla
-rw------- 1 root root 12 Oct 13 22:10 .nano_history
-rw-r--r-- 1 root root 140 Nov 19 2007 .profile
-rw-r--r-- 1 root root 0 Sep 11 17:55 .selected_editor
drwx------ 4 root root 4.0K Sep 9 23:27 .thumbnails
-rw------- 1 root root 200 Sep 11 17:11 .Xauthority
-rw------- 1 root root 14K Sep 11 23:11 .xsession-errors
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Analogue audio output gone with v136/JustBoom

Post by Fourdee »

Hi

You found a bug, nice one :)

Ok, you'll need to grab the updated function script, copy and paste all into term:

Code: Select all

wget https://github.com/Fourdee/DietPi/raw/1d14025c3aece5d39465867baec4c63a4fc62767/dietpi/func/dietpi-set_hardware -O /DietPi/dietpi/func/dietpi-set_hardware
dietpi-services stop
/DietPi/dietpi/func/dietpi-set_hardware soundcard h3-analogue
dietpi-services start
Sound should now be functional through 3.5mm analogue.

Interesting, onboard sound supports 192khz/32bit output, but no where near the sound quality of Odroid HiFi shield / JustBoom card:

Code: Select all

root@DietPi:~# cat /proc/asound/card*/pcm0p/sub0/hw_params
access: MMAP_INTERLEAVED
format: S32_LE
subformat: STD
channels: 2
rate: 192000 (192000/1)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
fhals

Re: Analogue audio output gone with v136/JustBoom

Post by fhals »

I'd rather say I stumbled upon something not working as intended and you found the bug.
Analogue audio is working again, thank you :D

Frans

BTW, my output is not that talkative:
root@DietPi:~# cat /proc/asound/card*/pcm0p/sub0/hw_params
closed
closed
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Analogue audio output gone with v136/JustBoom

Post by Fourdee »

fhals wrote: BTW, my output is not that talkative:
root@DietPi:~# cat /proc/asound/card*/pcm0p/sub0/hw_params
closed
closed
Hi Frans,

Command only works when a output stream is active (eg: playing audio).
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Sciamano
Posts: 264
Joined: Sat Oct 15, 2016 12:18 pm
Location: Italy

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by Sciamano »

Hello!
Has this been fixed?
I've installed LMS/Squeezelite on my OPi PC and I also receive the error:

Code: Select all

root@DietPi:~# alsamixer 
cannot open mixer: Invalid argument
I can hear sound from the 3.5mm jack after modifying the /etc/asound.conf file, but still I would like to set up alsamixer properly.
I have updated tu v137 but it still gives the same error.
Should I follow the steps described above too?
Thanks
fhals

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by fhals »

This has been fixed (at least for me).
The patch was built for v136 and fixed the issue.
After updating my installation from the patched v136 to official v137, my analogue audio is still working.
User avatar
Sciamano
Posts: 264
Joined: Sat Oct 15, 2016 12:18 pm
Location: Italy

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by Sciamano »

Analogue audio works for me too, but alsamixer still gives that error. :shock:
Post Reply