Change permissions to mounted ntfs drive Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
User avatar
Joulinar
Posts: 3339
Joined: Sat Nov 16, 2019 12:49 am

Re: Change permissions to mounted ntfs drive

Post by Joulinar »

that's how you export files systems usually using NFS
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
przemko
Posts: 146
Joined: Sun Mar 15, 2020 5:40 pm

Re: Change permissions to mounted ntfs drive

Post by przemko »

@Joulinar but if I don't have any entry here it shouldn't pass everyone?
I can mount that drive in nautilus as `sftp://192.168.0.24:/mnt/Seagate` but when I set that address in deja-dup to make backup it don't work.

regards.
User avatar
trendy
Posts: 201
Joined: Tue Feb 25, 2020 2:54 pm

Re: Change permissions to mounted ntfs drive

Post by trendy »

If you don't have any entry, how will the system know what do you want to share? It is a huge security risk to "just allow everything".
przemko
Posts: 146
Joined: Sun Mar 15, 2020 5:40 pm

Re: Change permissions to mounted ntfs drive

Post by przemko »

But It's only in my local home network. My first drive works without any entry.

regards.
User avatar
Joulinar
Posts: 3339
Joined: Sat Nov 16, 2019 12:49 am

Re: Change permissions to mounted ntfs drive

Post by Joulinar »

now I'm confused. Do you try to use SFTP or NFS?

Code: Select all

sftp://192.168.0.24:/mnt/Seagate
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
przemko
Posts: 146
Joined: Sun Mar 15, 2020 5:40 pm

Re: Change permissions to mounted ntfs drive

Post by przemko »

@Joulinar I want to use nfs mount on both drives. Now when I add entry to /ect/exports my Toshiba stop working on Ubutnu. I cannot access to /mnt/ folder on laptop.

Code: Select all

root@DietPi:/# cat /etc/exports
# /etc/exports: the access control list for filesystems which may be exported
#		to NFS clients.  See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes       hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)
#
# Example for NFSv4:
# /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)
/mnt/Seagate 192.168.0.*(rw,async,no_root_squash,fsid=0,crossmnt,no_subtree_check)
/mnt/Toshiba 192.168.0.*(rw,async,no_root_squash,fsid=0,crossmnt,no_subtree_check)
I try sfp to check it working.

regards.
przemko
Posts: 146
Joined: Sun Mar 15, 2020 5:40 pm

Re: Change permissions to mounted ntfs drive

Post by przemko »

When I reboot ubuntu lapton situation is even weirder. I have two times mounted that new drive. In /mnt/nas and in /mnt/Seagate.

Code: Select all

lusia@lusia-laptop:~$ cat /etc/fstab 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=07177a55-7bea-434d-876f-fe8550dec6ad /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda3 during installation
UUID=27a6b203-1463-484d-b0b1-e29056ec074b /home           ext4    defaults        0       2
# swap was on /dev/sda4 during installation
UUID=44edea65-65b0-484c-a846-8f992e5e890e none            swap    sw              0       0
# <file system>                             <dir>   <type>   <options>  <dump>	<pass>
192.168.0.24:/mnt/Toshiba/dietpi_userdata /mnt/nas  nfs      defaults    0       0
192.168.0.24:/mnt/Seagate /mnt/Seagate  nfs      defaults    0       0
How is that possible?
User avatar
trendy
Posts: 201
Joined: Tue Feb 25, 2020 2:54 pm

Re: Change permissions to mounted ntfs drive

Post by trendy »

przemko wrote: Tue Dec 22, 2020 2:31 pm I cannot access to /mnt/ folder on laptop.
Which is logical as the root directories are /mnt/Toshiba and /mnt/Seagate
przemko wrote: Tue Dec 22, 2020 2:31 pm I try sfp to check it working.
SFTP has nothing to do with NFS.

An example of the fstab entry in the NFS client is:

Code: Select all

10.0.2.5:/ /mnt/backup nfs _netdev,nofail,noauto,x-systemd.automount
In your case I am not sure how the server will distinguish the traffic for each share, so I suggest you merge them into one under /mnt and then use in clients the paths /Toshiba or /Seagate .
przemko
Posts: 146
Joined: Sun Mar 15, 2020 5:40 pm

Re: Change permissions to mounted ntfs drive

Post by przemko »

Hi @trendy, can You tell me how it's possible that when I do:
`sudo mount -t nfs 192.168.0.24:/mnt/Toshiba/dietpi_userdata/ /mnt/nas/` my laptop mount me my second Seagate drive in /mnt/nas. While /mnt/Seagate from Dietpi is mounted in /mnt/Seagate in ubuntu?

OK, I find error. I have the same fsid=0 in /etc/exports

regards.
przemko
Posts: 146
Joined: Sun Mar 15, 2020 5:40 pm

Re: Change permissions to mounted ntfs drive

Post by przemko »

Hi, one more thing @Joulinar. I start dietpi-sync now in my EasySSH terminal on ubuntu laptop. Can You tell me if I close that application window my sync will continue? Because when I copy folders in midnight commander it stops.

Image
Regards.
Post Reply