Not able to install SqueezeLite (Broken Packages) Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
maxpi
Posts: 8
Joined: Mon Dec 07, 2020 4:27 pm

Not able to install SqueezeLite (Broken Packages)

Post by maxpi »

Hello! First of all I'm not an expert, so sorry for that.
I have a RPi 3 and I'm trying to update to 6.33 but it always fails with this message:

[ SUB1 ] DietPi-Software > Installing SqueezeLite: audio player for lms & squeezebox
[ OK ] DietPi-Software | Checking URL: https://dietpi.com/downloads/binaries/s ... armv7l.deb
[ OK ] DietPi-Software | cd /tmp/DietPi-Software
[ OK ] DietPi-Software | curl -sSfL https://dietpi.com/downloads/binaries/s ... armv7l.deb -o 36.deb
[ INFO ] DietPi-Software | APT install for: ./36.deb, please wait...
E: Unable to correct problems, you have held broken packages.
[FAILED] DietPi-Software | APT install for: ./36.deb
- Command: apt-get -qq --allow-change-held-packages install ./36.deb

I tried reinstalling Squeezlite, and also deleting it. But now I can't install it again. The same message appears.

So I have two problems, I can't update and I can install Squizeelite.

As I said before, I'm not an expert, I read a lot (but sometimes beyond my comprehension ;·) and could not get a solution.
Any help will be appreciate it.
Thanks.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: Error updating to 6.33 (Broken Packages)

Post by Joulinar »

Hi,

Many thanks for your message. Pls can you do following

Code: Select all

apt update
apt upgrade
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
maxpi
Posts: 8
Joined: Mon Dec 07, 2020 4:27 pm

Re: Error updating to 6.33 (Broken Packages)

Post by maxpi »

Hi Joulinar! thanks for your answer.

With those commands the response is as follows:

root@DietPi:~# apt update
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 https://packages.sury.org/php stretch InRelease
Get:3 https://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Fetched 25.4 kB in 1s (19.1 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
root@DietPi:~# apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

hope it helps.
maxpi
Posts: 8
Joined: Mon Dec 07, 2020 4:27 pm

Re: Error updating to 6.33 (Broken Packages)

Post by maxpi »

I tried the following and maybe gives more information to the experts ;·)

root@DietPi:~# wget https://dietpi.com/downloads/binaries/s ... armv7l.deb
--2020-12-07 16:47:27-- https://dietpi.com/downloads/binaries/s ... armv7l.deb
Resolving dietpi.com (dietpi.com)... 104.27.178.199, 104.27.179.199, 172.67.173.4, ...
Connecting to dietpi.com (dietpi.com)|104.27.178.199|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 69722 (68K) [application/x-debian-package]
Saving to: ‘squeezelite_armv7l.deb’

squeezelite_armv7l.deb 100%[=========================================================>] 68.09K --.-KB/s in 0.02s

2020-12-07 16:47:27 (3.62 MB/s) - ‘squeezelite_armv7l.deb’ saved [69722/69722]

root@DietPi:~# apt install ./squeezelite_armv7l.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'squeezelite' instead of './squeezelite_armv7l.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
squeezelite : Depends: libmpg123-0 (>= 1.23.8-1+b1) but 1.23.8-1 is to be installed
E: Unable to correct problems, you have held broken packages.

Hope it helps.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: Error updating to 6.33 (Broken Packages)

Post by Joulinar »

yes quite useful information. Looks like an issue with one of the dependency libmpg123-0

Can you try to install this single package: apt --reinstall install libmpg123-0
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
maxpi
Posts: 8
Joined: Mon Dec 07, 2020 4:27 pm

Re: Error updating to 6.33 (Broken Packages)

Post by maxpi »

Hi Joulinar!

I was able to update to 6.33.3 before your reply. I don't know what changed but it was possible ;·)

Regarding your comment, I tried to install that single package without problems.

But Squeezelite still refuses to install. Same error as before:

root@DietPi:~# apt --reinstall install libmpg123-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 119 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ftp.cica.es/mirrors/Linux/raspbian/raspbian stretch/main armhf libmpg123-0 armhf 1.23.8-1 [119 kB]
Fetched 119 kB in 0s (267 kB/s)
(Reading database ... 40599 files and directories currently installed.)
Preparing to unpack .../libmpg123-0_1.23.8-1_armhf.deb ...
Unpacking libmpg123-0:armhf (1.23.8-1) over (1.23.8-1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Setting up libmpg123-0:armhf (1.23.8-1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
root@DietPi:~# dietpi-software install 36
[ OK ] DietPi-Software | Initialised database
[ OK ] DietPi-Software | Reading database
[ SUB1 ] DietPi-Software > Automated install
[ OK ] DietPi-Software | Installing SqueezeLite: audio player for lms & squeezebox
[ OK ] DietPi-Software | Free space check: path=/ | available=12296 MiB | required=500 MiB
[ OK ] DietPi-Software | DietPi-Userdata validation: /mnt/dietpi_userdata
[ OK ] DietPi-Software | Checking network connectivity
[ OK ] DietPi-Software | Checking DNS resolver
[ OK ] Network time sync | Completed
[ SUB2 ] DietPi-Services > unmask
[ OK ] DietPi-Services | unmask : avahi-daemon
[ OK ] DietPi-Services | unmask : proftpd
[ OK ] DietPi-Services | unmask : mariadb
[ OK ] DietPi-Services | unmask : php7.3-fpm
[ OK ] DietPi-Services | unmask : php7.4-fpm
[ OK ] DietPi-Services | unmask : lighttpd
[ OK ] DietPi-Services | unmask : mpd
[ OK ] DietPi-Services | unmask : shairport-sync
[ OK ] DietPi-Services | unmask : gmrender
[ OK ] DietPi-Services | unmask : networkaudiod
[ OK ] DietPi-Services | unmask : roonbridge
[ OK ] DietPi-Services | unmask : logitechmediaserver
[ OK ] DietPi-Services | unmask : netdata
[ OK ] DietPi-Services | unmask : cron
[ SUB2 ] DietPi-Services > stop
[ OK ] DietPi-Services | stop : cron
[ OK ] DietPi-Services | stop : netdata
[ OK ] DietPi-Services | stop : logitechmediaserver
[ OK ] DietPi-Services | stop : roonbridge
[ OK ] DietPi-Services | stop : networkaudiod
[ OK ] DietPi-Services | stop : gmrender
[ OK ] DietPi-Services | stop : shairport-sync
[ OK ] DietPi-Services | stop : mpd
[ OK ] DietPi-Services | stop : lighttpd
[ OK ] DietPi-Services | stop : php7.4-fpm
[ OK ] DietPi-Services | stop : php7.3-fpm
[ OK ] DietPi-Services | stop : mariadb
[ OK ] DietPi-Services | stop : proftpd
[ OK ] DietPi-Services | stop : avahi-daemon
[ OK ] DietPi-Software | mkdir -p /mnt/dietpi_userdata/Music /mnt/dietpi_userdata/Pictures /mnt/dietpi_userdata/Video /mnt/dietpi_userdata/downloads /var/www /opt
[ OK ] DietPi-Software | chown dietpi:dietpi /mnt/dietpi_userdata/Music /mnt/dietpi_userdata/Pictures /mnt/dietpi_userdata/Video /mnt/dietpi_userdata/downloads
[ OK ] DietPi-Software | chmod 775 /mnt/dietpi_userdata/Music /mnt/dietpi_userdata/Pictures /mnt/dietpi_userdata/Video /mnt/dietpi_userdata/downloads
[ SUB1 ] DietPi-Software > Update & upgrade APT
[ INFO ] DietPi-Software | APT update, please wait...
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Get:2 https://packages.sury.org/php stretch InRelease [6772 B]
Get:3 https://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Fetched 32.1 kB in 1s (21.1 kB/s)
Reading package lists...
[ OK ] DietPi-Software | APT update
[ INFO ] DietPi-Software | APT upgrade, please wait...
[ OK ] DietPi-Software | APT upgrade
[ SUB1 ] DietPi-Software > Checking for prerequisite software
[ INFO ] DietPi-Software | ALSA will be installed
[ SUB1 ] DietPi-Software > Installing ALSA: linux sound system
[ SUB2 ] DietPi-Set_hardware > soundcard (hw:1,0)
[ INFO ] DietPi-Set_hardware | Checking for required APT packages: alsa-utils
[ OK ] DietPi-Set_hardware | All required APT packages are already installed.
Found hardware: "USB-Audio" "USB Mixer" "USB278b:5100" "" ""
Hardware is initialized using a generic method
[ OK ] DietPi-Set_hardware | Desired setting in /boot/config.txt was already set: dtparam=audio=off
[ OK ] DietPi-Set_hardware | Desired setting in /boot/dietpi.txt was already set: CONFIG_SOUNDCARD=hw:1,0
[ OK ] soundcard hw:1,0 | Completed
[ SUB2 ] DietPi-Services > stop
[ OK ] DietPi-Services | stop : cron
[ OK ] DietPi-Services | stop : netdata
[ OK ] DietPi-Services | stop : logitechmediaserver
[ OK ] DietPi-Services | stop : roonbridge
[ OK ] DietPi-Services | stop : networkaudiod
[ OK ] DietPi-Services | stop : gmrender
[ OK ] DietPi-Services | stop : shairport-sync
[ OK ] DietPi-Services | stop : mpd
[ OK ] DietPi-Services | stop : lighttpd
[ OK ] DietPi-Services | stop : php7.4-fpm
[ OK ] DietPi-Services | stop : php7.3-fpm
[ OK ] DietPi-Services | stop : mariadb
[ OK ] DietPi-Services | stop : proftpd
[ OK ] DietPi-Services | stop : avahi-daemon
[ SUB1 ] DietPi-Software > Installing SqueezeLite: audio player for lms & squeezebox
[ OK ] DietPi-Software | Checking URL: https://dietpi.com/downloads/binaries/s ... armv7l.deb
[ OK ] DietPi-Software | cd /tmp/DietPi-Software
[ OK ] DietPi-Software | curl -sSfL https://dietpi.com/downloads/binaries/s ... armv7l.deb -o 36.deb
[ INFO ] DietPi-Software | APT install for: ./36.deb, please wait...
E: Unable to correct problems, you have held broken packages.

Any help on how to fix Squeezelite would be helpful.

On another side, do I have to start a new thread? Because now the problem is with Squeezelite and the held broken packages and not related to updating to 6.33.3. Let me know, thanks.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: Not able to install SqueezeLite (Broken Packages)

Post by Joulinar »

I changed the title as issues on installation of SqueezeLite was already reported on first post.

Basically the issue is with libmpg123-0 as it's expected to be installed on version >= 1.23.8-1+b1 but you have installed 1.23.8-1 (without +b1).

I did a test on a Stretch VM and correct version was installed. Can you have a look to apt show libmpg123-0

Code: Select all

root@DietPiVM3:~# apt show libmpg123-0
Package: libmpg123-0
Version: 1.23.8-1+b1
Priority: optional
Section: libs
Source: mpg123 (1.23.8-1)
Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Installed-Size: 359 kB
Depends: libc6 (>= 2.15)
Homepage: http://mpg123.org/
Tag: role::shared-lib
Download-Size: 137 kB
APT-Manual-Installed: no
APT-Sources: https://deb.debian.org/debian stretch/main amd64 Packages
Description: MPEG layer 1/2/3 audio decoder (shared library)

root@DietPiVM3:~#
Right now I don't have a RPi running Debian Stretch available to verify on Raspberry OS. Maybe tomorrow I can setup a Stretch system.

Just as side note, continue running Stretch is somehow a dead end road. Sooner or later you might consider to upgrade to Buster. I know it might not be easy as you have quite some applications running.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
maxpi
Posts: 8
Joined: Mon Dec 07, 2020 4:27 pm

Re: Not able to install SqueezeLite (Broken Packages)

Post by maxpi »

Hi Joulinar!

This is what I get with apt show libmpg123-0:

root@DietPi:~# apt show libmpg123-0
Package: libmpg123-0
Version: 1.23.8-1
Priority: optional
Section: libs
Source: mpg123
Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Installed-Size: 274 kB
Depends: libc6 (>= 2.15)
Homepage: http://mpg123.org/
Download-Size: 119 kB
APT-Manual-Installed: yes
APT-Sources: http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages
Description: MPEG layer 1/2/3 audio decoder (shared library)
mpg123 is a real time MPEG 1.0/2.0/2.5 audio player/decoder for layers
1, 2 and 3 (MPEG 1.0 layer 3 also known as MP3).
.
This package contains the C libraries needed to run executables that use
the mpg123 library.

As for Debian Strech... well that is what came with my USBBridge Sig, which by the way today is the first day I'm using it, and my first day with a linux system, so that change might take some time ;·)
Thanks for your help. I will try to see if I can figure it out, and if you have any new ideas to try, I'm all ears!

PD: thanks for changing the title.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: Not able to install SqueezeLite (Broken Packages)

Post by Joulinar »

you are running Allo Gui? And this is a fresh installed system? Maybe you can have a look to following image https://dietpi.com/downloads/images/Die ... AlloGUI.7z

To be on safe side, create an image of your SD card. Just to have a backup from original :) You never know
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
maxpi
Posts: 8
Joined: Mon Dec 07, 2020 4:27 pm

Re: Not able to install SqueezeLite (Broken Packages)

Post by maxpi »

Yes I'm running DietPi with Allo GUI. Fresh... well it is what came with the USB Bridge Sig, and Allo GUI told me that there was an update, and here we are ;·)
I'll take a look into the image, make a backup, etc, and report back. Thanks!
Post Reply