LXDE Fonts Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
flyg
Posts: 7
Joined: Fri Oct 30, 2020 4:14 pm

LXDE Fonts

Post by flyg »

Hi,

Setup LXDE and a VNC and I can connect through ok but all the fonts are squares - anyone know how to change this? maybe a config file somewhere for the system font or something?

failing that anyone that knows this interface on where to click to change the fonts?

thanks

attached a pic to show it.
Attachments
weirdquare.png
User avatar
Joulinar
Posts: 3257
Joined: Sat Nov 16, 2019 12:49 am

Re: LXDE Fonts

Post by Joulinar »

Hi,

many thanks for your message. That looks strange indeed. May I ask what VNC Viewer you are using? What language you have set on your system?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
flyg
Posts: 7
Joined: Fri Oct 30, 2020 4:14 pm

Re: LXDE Fonts

Post by flyg »

tiger vnc - just a default install of dietpi.

ive tried a few different GUi now and they also the same - is there something im missing in the dietpi files to confirm im english language?
User avatar
Joulinar
Posts: 3257
Joined: Sat Nov 16, 2019 12:49 am

Re: LXDE Fonts

Post by Joulinar »

usually there is just one point where you need to set your language dietpi-config > Language/Regional Options

What device you are running?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
flyg
Posts: 7
Joined: Fri Oct 30, 2020 4:14 pm

Re: LXDE Fonts

Post by flyg »

language is set to US.

Just using a normal PC as a pi.

Its strange - most GUI option desktops seem to use a square font but terminal outside GUI is totally fine.

Going to install them all and test.
User avatar
Joulinar
Posts: 3257
Joined: Sat Nov 16, 2019 12:49 am

Re: LXDE Fonts

Post by Joulinar »

Are you able to connect a screen if it is a normal PC? Maybe you can start the desktop without using VNC. Just to see how it is behaving.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
flyg
Posts: 7
Joined: Fri Oct 30, 2020 4:14 pm

Re: LXDE Fonts

Post by flyg »

thanks for your help but I ended up doing it the ultimate way and it worked!

backup up all my pi settings, wiped it all then reinstalled and restored settings and now its working :D

so must have been a system thing somewhere that got wiped out with the backup and restore onto a fresh isntall.
User avatar
Joulinar
Posts: 3257
Joined: Sat Nov 16, 2019 12:49 am

Re: LXDE Fonts

Post by Joulinar »

ok good it's working now. probably some corrupted font files.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply