SSH - Never get to prompt ! Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
User avatar
trendy
Posts: 200
Joined: Tue Feb 25, 2020 2:54 pm

Re: SSH - Never get to prompt !

Post by trendy »

  1. Did you disconnect all other devices from the network, leaving the PC and the RPi only?
  2. Also can you explain a bit the infrastructure you have there? Are both devices connected over the router or are there other devices, like switches, access points?
  3. Do you have full control you and only you over these devices?
  4. Are you using anytype of firewall, antivirus, antimalware on the RPi?
  5. Have you tried to boot a clean installation of dietpi on a different SD card?
SimonFili
Posts: 23
Joined: Sun Nov 22, 2020 4:43 pm

Re: SSH - Never get to prompt !

Post by SimonFili »

@trendy

Just tried a separate Wi-Fi created with my phone. A laptop to PiZero on this "private" network, Putty port 22 works fine.

Reactivated the wifi on the Bell router, connected a laptop and the PiZ, ssh works.

So seems to be the AP TP-LIKN EAP245 with an issue

I'm wondering if being on the same SSID and the laptop connected with 5G and the Pi with 2.4G would be an issue?

Here's a rough drawing of my setup. Redlines are ssh not working, green are ssh working.
DebugPiNetwork.png
Thanks
User avatar
Joulinar
Posts: 3259
Joined: Sat Nov 16, 2019 12:49 am

Re: SSH - Never get to prompt !

Post by Joulinar »

did you tried to disable 5GHz WiFi and continue running on 2.4GHz only? Just to see how it's behaving?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
trendy
Posts: 200
Joined: Tue Feb 25, 2020 2:54 pm

Re: SSH - Never get to prompt !

Post by trendy »

SimonFili wrote: Fri Dec 04, 2020 9:19 pm I'm wondering if being on the same SSID and the laptop connected with 5G and the Pi with 2.4G would be an issue?
It should not be an issue. But give it a try.
Is the Access Point EAP245 running on latest firmware? I would try to factore restore it and apply a bare minimum configuration to make sure it works.
SimonFili
Posts: 23
Joined: Sun Nov 22, 2020 4:43 pm

Re: SSH - Never get to prompt !

Post by SimonFili »

Tested on a 2.4G only SSID. Connected both PiZero and laptop, same issue. So it's not an issue of 2.4G vs 5G

Then I tested another laptop connected with a wired connection to connect to the PiZero on a 2.4G wifi. So not going through wifi on the Putty side did not change that Putty cannot connect.

So...

Laptop (EAP245 wifi 5G) > PiZero (EAP245 2.4G) SSH on port 22 = Not working
Laptop (EAP245 wifi 5G) > PiZero (EAP245 2.4G) SSH on port 2222 = working
Laptop (EAP245 wifi 2.G) > PiZero (EAP245 2.4G) SSH on port 22 = Not working
Laptop (wired) > PiZero (EAP245 2.4G) SSH on port 22 = Not working
Laptop (Phone Wifi) > PiZero (Phone Wifi ) SSH on port 22 = working
Laptop (Bell-router Wifi) > PiZero (Bell router) SSH on port 22 = working

So, the issue is around port 22 over my EAP245 Wifi.

I checked the EAP245 config, no SSH is configured/activated on it. Firmware is up2date.
I don't have issues doing ssh (putty) to remote servers over VPN/DirectAccess with the Wifi on EAP245

So, I'm about to close this case and put the PiZero ssh port to 2222
SimonFili
Posts: 23
Joined: Sun Nov 22, 2020 4:43 pm

Re: SSH - Never get to prompt !

Post by SimonFili »

Ok! So I went back to port 2222... did not work like before! Then changed to port 1234... did not work... WTF!

So I reboot the AP EAP245 and bang, worked!

So it's really the EAP245 which is buggy!

Went back to port 22... no issue!

I will open a ticket to TP-LINK

What a complicated path to find an issue... never thought an AP could be buggy for a specific protocol like SSH, since I'm doing a lot of SSH to work servers.

Thanks for all the brainstorming help guys... really appreciative.
User avatar
Joulinar
Posts: 3259
Joined: Sat Nov 16, 2019 12:49 am

Re: SSH - Never get to prompt !

Post by Joulinar »

Indeed quite strange an AP could have such influence. But good we found it. Even if it was a long way :)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply