Services fail to start after updating to v6.33.3

Having issues with your DietPi installation, or, found a bug? Post it here.
Ale
Posts: 7
Joined: Thu Oct 29, 2020 10:47 am

Re: Services fail to start after updating to v6.33.3

Post by Ale »

here it is:
root@pi4:~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 29G 14G 14G 51% /
devtmpfs 1.9G 0 1.9G 0% /dev
tmpfs 1.9G 1.3M 1.9G 1% /dev/shm
tmpfs 1.9G 17M 1.9G 1% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 1.9G 0 1.9G 0% /sys/fs/cgroup
tmpfs 50M 1.7M 49M 4% /var/log
tmpfs 2.0G 4.0K 2.0G 1% /tmp
/dev/mmcblk0p1 253M 61M 192M 24% /boot
//172.16.0.3/Data 5.5T 2.3T 3.2T 43% /mnt/nas

I don't have any external drive apart from the microSD on which the os is installed...

thanks for your help
User avatar
Joulinar
Posts: 2572
Joined: Sat Nov 16, 2019 12:49 am

Re: Services fail to start after updating to v6.33.3

Post by Joulinar »

ok it seems /run is correctly mounted. Just to be sure. It's empty right? pls can you check ls -la /run

I guess we would need support from the developer @MichaIng.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Ale
Posts: 7
Joined: Thu Oct 29, 2020 10:47 am

Re: Services fail to start after updating to v6.33.3

Post by Ale »

/run is not empty, I think it's just missing the dietpi folder...

root@pi4:~# ls -la /run
total 44
drwxr-xr-x 20 root root 700 Oct 29 12:26 .
drwxr-xr-x 21 root root 4096 Jun 8 11:05 ..
-rw------- 1 root root 0 Oct 29 09:24 agetty.reload
drwxr-xr-x 2 root root 80 Oct 29 09:24 blkid
drwxr-xr-x 2 root root 80 Oct 29 09:24 console-setup
-rw-r--r-- 1 root root 4 Oct 29 09:24 crond.pid
---------- 1 root root 0 Oct 29 09:24 crond.reboot
drwxr-xr-x 2 root root 80 Oct 29 09:24 fail2ban
prw------- 1 root root 0 Feb 14 2019 initctl
-rw------- 1 root root 4 Oct 29 09:24 iscsid.pid
-rw-r--r-- 1 root root 4 Oct 29 09:24 lighttpd.pid
drwxrwxrwt 2 root root 40 Feb 14 2019 lock
drwxr-xr-x 3 root root 60 Feb 14 2019 log
drwxr-xr-x 2 www-data www-data 40 Oct 29 09:24 mono-xsp4
-rw-r--r-- 1 root root 4 Oct 29 09:24 mono-xsp4.pid
-rw-r--r-- 1 root root 68 Oct 29 12:26 motd.dynamic
drwxr-xr-x 2 root root 80 Oct 29 09:24 mount
drwxr-xr-x 2 mysql root 80 Oct 29 09:24 mysqld
drwxr-xr-x 2 root root 120 Oct 29 09:24 network
drwxr-xr-x 2 pihole pihole 60 Oct 29 09:24 pihole
-rw-r--r-- 1 pihole pihole 3 Oct 29 09:24 pihole-FTL.pid
-rw-r--r-- 1 pihole pihole 4 Oct 29 09:24 pihole-FTL.port
drwxr-sr-x 2 redis redis 80 Oct 29 09:24 redis
-rw-r--r-- 1 root root 4 Oct 29 09:24 rngd.pid
dr-xr-xr-x 11 root root 0 Feb 14 2019 rpc_pipefs
drwxr-x--- 2 _rpc root 40 Oct 29 09:24 rpcbind
-r--r--r-- 1 root root 0 Oct 29 09:24 rpcbind.lock
srw-rw-rw- 1 root root 0 Feb 14 2019 rpcbind.sock
-rw-rw-rw- 1 root root 12 Oct 29 09:24 rpimonitord.pid
drwxr-xr-x 2 root root 40 Oct 29 09:24 sshd
-rw-r--r-- 1 root root 4 Oct 29 09:24 sshd.pid
drwxr-xr-x 2 root root 60 Feb 14 2019 sysconfig
drwxr-xr-x 11 root root 280 Oct 29 09:30 systemd
drwxr-xr-x 2 root root 60 Feb 14 2019 tmpfiles.d
drwxr-xr-x 7 root root 160 Oct 29 09:24 udev
User avatar
Joulinar
Posts: 2572
Joined: Sat Nov 16, 2019 12:49 am

Re: Services fail to start after updating to v6.33.3

Post by Joulinar »

ok quite strange, you are missing /run/dietpi/ as well as /run/php

let me open a GitHub issue to have the developer a look into it.

DONE: https://github.com/MichaIng/DietPi/issues/3877
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
claudiuh
Posts: 5
Joined: Wed Oct 21, 2020 9:29 pm

Re: Services fail to start after updating to v6.33.3

Post by claudiuh »

Joulinar wrote: Thu Oct 29, 2020 1:58 pm ok quite strange, you are missing /run/dietpi/ as well as /run/php

let me open a GitHub issue to have the developer a look into it.

DONE: https://github.com/MichaIng/DietPi/issues/3877
That's exactly what happened to me Now, i'm running v6.33.3 wich i dowloaded and installed. For now all is working fine.
User avatar
MichaIng
Site Admin
Posts: 2422
Joined: Sat Nov 18, 2017 6:21 pm

Re: Services fail to start after updating to v6.33.3

Post by MichaIng »

/run/dietpi is created during boot via: /etc/tmpfiles.d/dietpi.conf
/run/php should be created by the same mechanism via: /usr/lib/tmpfiles.d/php7.3-fpm.conf
Depending on when PHP was (re)installed through dietpi-software also /run/php_sessions should exist, created via: /etc/tmpfiles.d/dietpi-php.conf

/run itself is mounted by systemd but I am not sure if there is any specific systemd unit responsible, or when this is done, to compare timestamps :?.
However can you check if all above files exist with fine content and: journalctl -u systemd-tmpfiles-setup
Ale
Posts: 7
Joined: Thu Oct 29, 2020 10:47 am

Re: Services fail to start after updating to v6.33.3

Post by Ale »

/etc/tmpfiles.d/dietpi-php.conf is the only one missing. Here is the content:

root@pi4:/# cat /etc/tmpfiles.d/dietpi.conf
d /run/dietpi 0777
root@pi4:/# cat /usr/lib/tmpfiles.d/php7.3-fpm.conf
#Type Path Mode UID GID Age Argument
d /run/php 0755 www-data www-data - -
root@pi4:/# ls -la /etc/tmpfiles.d/
total 12
drwxr-xr-x 2 root root 4096 Jul 26 11:34 .
drwxr-xr-x 89 root root 4096 Oct 29 08:46 ..
-rw-r--r-- 1 root root 19 Oct 29 08:44 dietpi.conf
root@pi4:/# journalctl -u systemd-tmpfiles-setup
-- Logs begin at Thu 2019-02-14 10:11:58 GMT, end at Thu 2020-10-29 16:05:02 GMT. --
-- No entries --
root@pi4:/#

Thanks a bunch for your help
User avatar
Joulinar
Posts: 2572
Joined: Sat Nov 16, 2019 12:49 am

Re: Services fail to start after updating to v6.33.3

Post by Joulinar »

hm there is no entry for the systemd-tmpfiles-setup service. :?
Usually it should give something like this

Code: Select all

root@DietPi3:~# journalctl -u systemd-tmpfiles-setup
-- Logs begin at Thu 2020-10-29 16:25:53 CET, end at Thu 2020-10-29 19:18:17 CET. --
Oct 29 16:25:55 DietPi3 systemd[1]: Starting Create Volatile Files and Directories...
Oct 29 16:25:55 DietPi3 systemd[1]: Started Create Volatile Files and Directories.
root@DietPi3:~#
pls can you check status

Code: Select all

systemctl status systemd-tmpfiles-setup
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Ale
Posts: 7
Joined: Thu Oct 29, 2020 10:47 am

Re: Services fail to start after updating to v6.33.3

Post by Ale »

root@pi4:~# systemctl status systemd-tmpfiles-setup
● systemd-tmpfiles-setup.service - Create Volatile Files and Directories
Loaded: loaded (/lib/systemd/system/systemd-tmpfiles-setup.service; static; vendor preset: enabled)
Active: inactive (dead)
Docs: man:tmpfiles.d(5)
man:systemd-tmpfiles(8)

loaded but inactive?
User avatar
Joulinar
Posts: 2572
Joined: Sat Nov 16, 2019 12:49 am

Re: Services fail to start after updating to v6.33.3

Post by Joulinar »

can you try to restart the service?

Code: Select all

systemctl restart systemd-tmpfiles-setup
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply