Using RAID 1 for system and data - media server?

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
OwenJoseph
Posts: 8
Joined: Wed Aug 19, 2020 11:43 am

Using RAID 1 for system and data - media server?

Post by OwenJoseph »

Hi,
I'm building up a Raspberry Pi 4 as a replacement to a dead MacMini.
It will mostly be Plex and centrally stored picture library.
I have a dual bay 2.5 inch USB 3 enclosure and two 2Tb disks to use.
Options are. I could use them in RAID 1 for some redundancy of data - would also be backed up elsewhere, or I could use them in JBOD and sync regularly between the two.
Which would be better?
Last edited by OwenJoseph on Fri Aug 28, 2020 7:46 am, edited 1 time in total.
User avatar
Joulinar
Posts: 2287
Joined: Sat Nov 16, 2019 12:49 am

Re: Using RAID 1 for system and data - media server?

Post by Joulinar »

Hi,

many thanks for your question. Basically it's same question like this viewtopic.php?f=9&t=7787
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
lucky001
Posts: 1
Joined: Thu Aug 27, 2020 9:21 am

Re: Using RAID 1 for system and data - media server?

Post by lucky001 »

Hi,
I have a similar setup so I here is my experience.
Pi 4 4Gb, original PSU.
DietPi x64 alpha (faster and stable).
Booting from an SSD (new beta VL firmware) inside an Orico (VL715 chipset) enclosure. No need to copy anything, just flashed the beta EEPROM firmware.
USB Hub (VIA VL817 chip) feeded from an extension cord with charging hub (max 3 amps).
External 3.5 case, 3Tb, backup drive.
Raid enclosure (JMS561 chip, 2x2TB 2.5, JBOD mode, software BTRFS raid1). Using BTRBK to take regular snapshots of subvols and send a copy to backup drive. This is also feeded from extension cord Hub and perhaps the VIA Hub (backfeeding via USB cable).
Connecting the Raid enclosure directly to Pi (without dedicated PSU) => to much for Pi current back feed from usbUSB (max 2 amps) to power both drives. Using just the dedicated PSU on Raid enclosure provides backfeeding to Pi => bus reset errors.
Using Raid > Hub > Pi => no more backfeeding (but regular bus reset when transferring Gigs of data or scrubbing)
Updating to x64 alpha solved all the problems (uptime 7 days, no errors, no quirks, UAS on all ports).

So, If you have 2 disks and want to use them for streaming but also want some redundancy and perhaps error control you could make 2 partitions on each, use a pair of them (sda1+sdb1) in Raid1 btrfs (your library) then send data to backup, and for the other pair (sda2+sdb2) you could use raid1 btrfs, lvm etc.
Beware of phisical disk wearing, maybe you should set them to always on (using hdparm sleep/APM) and monitor SMART (manually 'smartctl -d sat' or using smartmontools/smartd).
User avatar
WarHawk
Posts: 621
Joined: Thu Jul 20, 2017 8:55 am

Re: Using RAID 1 for system and data - media server?

Post by WarHawk »

I wonder if a NAS software solution wouldn't be more apt

OpenMediaVault has a ARM port...

Not sure how to build a RAID1 on Dietpi however (one of the dev's might know alot more on that)

You could also look into doing rsync...use one drive as the standard user data drive, then rsync that drive to the "backup" drive periodically with a crontab entry
Post Reply