will Docker install bork my Radarr?

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
ainuke
Posts: 14
Joined: Tue Jun 09, 2020 8:44 pm

will Docker install bork my Radarr?

Post by ainuke »

Hi,

I was starting to install Docker on DietPi so I could run a LazyLibrarian container, but partway through, there was an identified conflict with installing Mono. Based on other issues installing Sonarr prior to finding DietPi, Sonarr uses an outdated version of Mono (v5.10) and locks the version to that. I'd hate to kill my current working setup of Son-Rad-Lid-arr by screwing with the Mono conflicts. Not even sure the Docker install will progress with the conflict; I killed the install as soon as I saw the issue.

So do I:

1. ignore the Mono conflict and cross my fingers that it's all good?
2. be happy with the -arrs and give up on LL
3. attempt installing LL straight-up as if it's vanilla Debian? Not looking forward to figuring out how to move all the relevant files to the SSD where DietPi appdata is located...

What advice do you have?
Erik
Official Pi4 4GB
LoveRPi POE HAT, ArgonOne Fan HAT, WD SSD over USB3
SAB, Sonarr, Radarr, Lidarr, Deluge, PIA-VPN

Official Pi4 4GB - attempting Mine OS

"The mistakes you learn from don't have to be your own."
ainuke
Posts: 14
Joined: Tue Jun 09, 2020 8:44 pm

Re: will Docker install bork my Radarr?

Post by ainuke »

Way down on the list of options would be to run it in a Docker on my unRAID box. The issue then would be routing all the search/download/etc through the VPN on the DietPi.
Official Pi4 4GB
LoveRPi POE HAT, ArgonOne Fan HAT, WD SSD over USB3
SAB, Sonarr, Radarr, Lidarr, Deluge, PIA-VPN

Official Pi4 4GB - attempting Mine OS

"The mistakes you learn from don't have to be your own."
User avatar
Joulinar
Posts: 2064
Joined: Sat Nov 16, 2019 12:49 am

Re: will Docker install bork my Radarr?

Post by Joulinar »

Hi,

if you install Sonarr today, you will get installed Mono 6.10 from mono-project

https://www.mono-project.com/docs/about-mono/releases/

Not sure why it should be locked to 5.10
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
ainuke
Posts: 14
Joined: Tue Jun 09, 2020 8:44 pm

Re: will Docker install bork my Radarr?

Post by ainuke »

Joulinar wrote: Wed Aug 12, 2020 8:25 pm
Not sure why it should be locked to 5.10
There was an issue with v6 regarding SMB shares. I believe MichaINg has commented about it on other topics; It's what put DietPi on my radar (no pun intended) to begin with...

If I were to run a manual update of Sonarr, do you think it'll pick up the Mono v6 unlock, or am I looking at a reinstall. If reinstall, will DietPi keep my appdata and settings?

Thanks for your help.
Erik
Official Pi4 4GB
LoveRPi POE HAT, ArgonOne Fan HAT, WD SSD over USB3
SAB, Sonarr, Radarr, Lidarr, Deluge, PIA-VPN

Official Pi4 4GB - attempting Mine OS

"The mistakes you learn from don't have to be your own."
User avatar
Joulinar
Posts: 2064
Joined: Sat Nov 16, 2019 12:49 am

Re: will Docker install bork my Radarr?

Post by Joulinar »

yes there was/is an issue with mono v6 and CIFS. Recommendation was to downgrade to mono v5 or upgrade to Sonarr v3 beta. However this require manuell user intervention. By default you will get latest version available (mono 6.10), independent of the issue. But honestly I'm not sure if this has been fixed with mono 6.10.

https://github.com/MichaIng/DietPi/issues/3179
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
ainuke
Posts: 14
Joined: Tue Jun 09, 2020 8:44 pm

Re: will Docker install bork my Radarr?

Post by ainuke »

Yeah that’s the one. IIRC Sonarr v3 has all the Mono dependencies included, and may lock the Mono version to 5.x for updates; I haven’t checked /sources but I bet it’s there. This issue was my first experience with a Linux install, and let me tell you, when I saw the Mono 5.10 conflict pop up installing Docker, I had a bit of PTSD.

But now I’ve shed WHS2011 in favor of unRAID for my server, so I’m curious if Mono V6 is a problem for me any more.

Thank you for your insight.
Erik
Official Pi4 4GB
LoveRPi POE HAT, ArgonOne Fan HAT, WD SSD over USB3
SAB, Sonarr, Radarr, Lidarr, Deluge, PIA-VPN

Official Pi4 4GB - attempting Mine OS

"The mistakes you learn from don't have to be your own."
User avatar
Joulinar
Posts: 2064
Joined: Sat Nov 16, 2019 12:49 am

Re: will Docker install bork my Radarr?

Post by Joulinar »

there are a couple of ways to block packages from being updated.

https://www.tecmint.com/disable-lock-bl ... ebian-apt/
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply