KODI will not install on ARMv8-Buster RPI 3 B+ Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
jonyskids
Posts: 13
Joined: Thu Nov 16, 2017 3:21 pm

KODI will not install on ARMv8-Buster RPI 3 B+

Post by jonyskids »

Completely clean install and I get the following during Instal of Kodi:

APT install for: libcec4 libcurl3-gnutls libnfs12 kodi fbset │
│ - Command: apt-get -qq --allow-change-held-packages install libcec4 │
│ libcurl3-gnutls libnfs12 kodi fbset │
│ - Exit code: 100 │
│ - DietPi version: v6.31.2 (MichaIng/master) | HW_MODEL: 3 | HW_ARCH: 3 | │
│ DISTRO: 5 │
│ - Image creator: DietPi Core Team │
│ - Pre-image: Raspberry Pi OS (64-bit) │
│ - Error log: │
│ E: Unable to correct problems, you have held broken packages.

Any help would be appreciated.

Thanks.
User avatar
Joulinar
Posts: 2091
Joined: Sat Nov 16, 2019 12:49 am

Re: KODI will not install on ARMv8-Buster RPI 3 B+

Post by Joulinar »

Hi,

many thanks for your report. Pls can you try running apt update && apt upgrade
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
jonyskids
Posts: 13
Joined: Thu Nov 16, 2017 3:21 pm

Re: KODI will not install on ARMv8-Buster RPI 3 B+

Post by jonyskids »

All zeros returned. Same results when I try to install Kodi.

Thanks for the help.
User avatar
Joulinar
Posts: 2091
Joined: Sat Nov 16, 2019 12:49 am

Re: KODI will not install on ARMv8-Buster RPI 3 B+

Post by Joulinar »

All zeros returned.
what does this means?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
jonyskids
Posts: 13
Joined: Thu Nov 16, 2017 3:21 pm

Re: KODI will not install on ARMv8-Buster RPI 3 B+

Post by jonyskids »

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

After running: apt update && apt upgrade
User avatar
Joulinar
Posts: 2091
Joined: Sat Nov 16, 2019 12:49 am

Re: KODI will not install on ARMv8-Buster RPI 3 B+

Post by Joulinar »

pls do apt install libcec4
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
jonyskids
Posts: 13
Joined: Thu Nov 16, 2017 3:21 pm

Re: KODI will not install on ARMv8-Buster RPI 3 B+

Post by jonyskids »

libcec4 is already the newest version (4.0.4+dfsg1-2+rpi1+rpt1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
User avatar
Joulinar
Posts: 2091
Joined: Sat Nov 16, 2019 12:49 am

Re: KODI will not install on ARMv8-Buster RPI 3 B+

Post by Joulinar »

and trying to install Kodi will bring same error message still?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
jonyskids
Posts: 13
Joined: Thu Nov 16, 2017 3:21 pm

Re: KODI will not install on ARMv8-Buster RPI 3 B+

Post by jonyskids »

Yes, Same result.
User avatar
Joulinar
Posts: 2091
Joined: Sat Nov 16, 2019 12:49 am

Re: KODI will not install on ARMv8-Buster RPI 3 B+

Post by Joulinar »

ok issue is with Kodi package 18.7 on Raspberry OS 64bit. It doesn't seems to be available on Debian repository

https://forum.kodi.tv/showthread.php?tid=354921

using 32bit image instead, and kodi should be working
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply