(resolved) ODROID-XU4 Cloudshell v2 - custom USB mount

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
AarDVark

(resolved) ODROID-XU4 Cloudshell v2 - custom USB mount

Post by AarDVark »

Hi!

By the way, excellent work on DietPi! This is the best stripped down linux server image I've ever found!

I Have a little problem with Cloudshell not displaying the USB Storage information. I think the problem is that I mounted my drive as the /home/ folder, originally the drive was mounted in /mnt/usb_1/ in the /etc/fstab file.

Is there is a way of configuring the Cloudshell script to "look" in different folder?

In case it may help here is my fstab configuration :

Code: Select all

#Internal Drives---------------------------------------------------
/dev/mmcblk0p2  /            ext4      defaults,errors=remount-ro,noatime                      0       1
/dev/mmcblk0p1  /boot        vfat      defaults,rw,owner,flush,umask=000                       0       2
tmpfs           /tmp         tmpfs     noatime,nodev,nosuid,mode=1777                          0       0
#/var/log DietPi Ramlog Disabled
tmpfs           /DietPi      tmpfs     defaults,size=10m,noatime,nodev,nosuid,mode=1777        0       0

#External Drives---------------------------------------------------
# - Try and use only ext4 for USB drives
# - Faster performance than NTFS, espically on Pi
/dev/sda1       /home           ext4    defaults,noatime,nobootwait     0       2
#/dev/sda1      /mnt/usb_1      ntfs-3g defaults,nobootwait             0       0
Also, I tried to mount the drive using the HDD UUID but Cloudshell still do not show USB Storage usage

Thanks!
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: ODROID-XU4 Cloudshell v2 not showing USB Storage info

Post by Fourdee »

Hi AarDVark,

Yes, the location can be changed. Currently, you will need to modify the dietpi-cloudshell script. I will add this option to the settings file at a later date.

Use /home as the USB drive in dietpi-cloudshell:

Code: Select all

sed -i "/STORAGE_USB_PATH=/c\STORAGE_USB_PATH='/home'" /DietPi/dietpi/dietpi-cloudshell
killall dietpi-cloudshell
/DietPi/dietpi/dietpi-cloudshell 0 &> /dev/tty0 &
AarDVark wrote:Hi! By the way, excellent work on DietPi! This is the best stripped down linux server image I've ever found!
Great to hear! Be sure to spread the word :)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
AarDVark

Re: ODROID-XU4 Cloudshell v2 not showing USB Storage info

Post by AarDVark »

It works, Thanks! ;)
Post Reply