Feature request - cloudshell XU4

Suggestions for features and software you would like to see in DietPi, goes here.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Feature request - cloudshell XU4

Post by Fourdee »

johnvick wrote:Hi Fourdee,

Still intermittently getting this message and all drives present with df -h. Sometimes the root fs drive is reported as "Mount not active" which is a bit of a paradox.

John
Hi John,

I've updated the script to provide a little more information. I believe df is failing to respond (timing out). If i remember correctly, are you running any NFS mounts on this system?

We currently allow for 4 seconds, before we terminate the df process if it doesnt respond. As previously, this prevents it locking up the Cloudshell stats in NFS drop situations,

Get new script:

Code: Select all

wget https://raw.githubusercontent.com/Fourdee/DietPi/testing/dietpi/dietpi-cloudshell -O /DietPi/dietpi/dietpi-cloudshell
If df fails to respond, error log will be created here, and, you'll also get a "DF failed" print on the scene:

Code: Select all

/var/log/dietpi-cloudshell.log
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Feature request - cloudshell XU4

Post by johnvick »

Hi Fourdee,

Thanks for the update - but no change here. Sometime I have a correct display, sometime it is the "Mount not cative message".

I have NFS shares on a QNAP but it doesn't make any difference if this is powered up or not. I drives I reference in Cloudshell are local - a USB flask and an SSD.

John
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Feature request - cloudshell XU4

Post by Fourdee »

Hi John,

Really strange.

Checked the code. It appears df is returning a result, but for some reason, the result is missing your mounted drives. Basically this means the drive isn't mounted at that time, which is bizarre lol.

Lets check dmesg for any mounting information
If you get a chance, could you please paste/upload the results of:

Code: Select all

dmesg
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Feature request - cloudshell XU4

Post by johnvick »

HI Fourdee,

Too big for here so here's the link:

http://pastebin.com/WPyL6hUu

John
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Feature request - cloudshell XU4

Post by Fourdee »

johnvick wrote:HI Fourdee,

Too big for here so here's the link:

http://pastebin.com/WPyL6hUu

John
Hi John,

Thanks.

Only appears we have logs for 32 seconds after boot. If any errors occurred afterwards, they should be time stamped.
[ 8.292214] [c7] sdb: unknown partition table
[ 8.340711] [c7] EXT4-fs (sdb): mounting with "discard" option, but the device does not support discard
[ 8.341533] [c7] EXT4-fs (sdb): mounted filesystem with ordered data mode. Opts: discard
Strange, it reports a unknown partition table (note: maybe it doesn't like GPT, prefers MBR?), yet mounts it fine. Can you remember how this drive was originally formatted (eg: through dietpi-drive_manager or elsewhere)?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Feature request - cloudshell XU4

Post by johnvick »

Fourdee wrote:
johnvick wrote:HI Fourdee,

Too big for here so here's the link:

http://pastebin.com/WPyL6hUu

John
Hi John,

Thanks.

Only appears we have logs for 32 seconds after boot. If any errors occurred afterwards, they should be time stamped.
[ 8.292214] [c7] sdb: unknown partition table
[ 8.340711] [c7] EXT4-fs (sdb): mounting with "discard" option, but the device does not support discard
[ 8.341533] [c7] EXT4-fs (sdb): mounted filesystem with ordered data mode. Opts: discard
Strange, it reports a unknown partition table (note: maybe it doesn't like GPT, prefers MBR?), yet mounts it fine. Can you remember how this drive was originally formatted (eg: through dietpi-drive_manager or elsewhere)?

I think I formatted this from the command line but I can't really remember - this is a 120 GB SSD.

I'll reformat through DietPi later today and see if that makes any difference.

John
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Feature request - cloudshell XU4

Post by johnvick »

Hi Fourdee,

Reformatted the SSD with dietpi drive manager and mounted as usb_2.

Still the same "Mount not active" message on the eMMC and SSD drives - the USB flash drive does not show this message. The numbers look as they should be for all three drives.

The dmesg is here:

http://pastebin.com/KNq7qfq7

Thanks for you help with this I am not sure where to go from here.

John
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Feature request - cloudshell XU4

Post by Fourdee »

johnvick wrote: The dmesg is here:

http://pastebin.com/KNq7qfq7

Thanks for you help with this I am not sure where to go from here.

John
Thanks John, I'll take a look and get back to you within a few days (NanoPi's turned up, image'r'us ;) lol)
https://github.com/Fourdee/DietPi/issues/603
https://github.com/Fourdee/DietPi/issues/602
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Feature request - cloudshell XU4

Post by johnvick »

Hi Fourdee,

Thanks for following up on this - the numbers on the display are fine the only irregularity is the "mount not active" error - this doesn't worry me but I know you'll want this working perfectly.

Any other cloudshell users tested this?

John
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Feature request - cloudshell XU4

Post by Fourdee »

Hi John,

Dmesg looks fine.

I've added some extra debug/logging code to the script, should give us some useful information on the cause:

Code: Select all

wget https://raw.githubusercontent.com/Fourdee/DietPi/testing/dietpi/dietpi-cloudshell -O /DietPi/dietpi/dietpi-cloudshell
Reboot system.

When you notice the "Mount not active" message, check the log file and paste results please:

Code: Select all

cat /var/log/dietpi-cloudshell.log
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply