Change default landing page NGINX to Nextcloud Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
zartarr88
Posts: 20
Joined: Sun Jul 05, 2020 4:18 am

Change default landing page NGINX to Nextcloud

Post by zartarr88 »

Hey guys,
total noob here but got a Nextcloud server up an running thanks to this phenomenal software. Issue I'm having is that when I go to my website the landing page is the default Apache html page . but if I go to mywebsite.com/nextcloud I do end up getting to my server. I was wondering how would I go about changing it so it lands on my nextcloud page.

Heads up I'm a total noob, but I think the reason its showing the Apache page is because I initially had Apache server, then changed it to NGINX.
User avatar
Joulinar
Posts: 2600
Joined: Sat Nov 16, 2019 12:49 am

Re: Change default landing page NGINX to Nextcloud

Post by Joulinar »

Hi,

many thanks for your request. In principle it's correct that you get default web server side displayed as this is document root. Nextcloud is just a sub directory. Anyway before trying to reconfigure web server, let's check which one is running. Usualy you should get displayed Nginx default website and not Apache. Pls can you post following

Code: Select all

dietpi-services status
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
zartarr88
Posts: 20
Joined: Sun Jul 05, 2020 4:18 am

Re: Change default landing page NGINX to Nextcloud

Post by zartarr88 »

Dear Joulinar, many thanks for your help ;

Just a heads up I am also running into error in nextcloud when uploading files. 2 of them
1) Error when assembling chunks, status code 504
2) will edit report back , forgot what this was but I believe it was 502


the output you requested:

Code: Select all

 Mode: status 

[  OK  ] DietPi-Services | proftpd		active (running) since Sun 2020-07-05 10:45:58 BST; 12h ago
[  OK  ] DietPi-Services | redis-server		active (running) since Sun 2020-07-05 10:45:59 BST; 12h ago
[  OK  ] DietPi-Services | mariadb		active (running) since Sun 2020-07-05 10:46:02 BST; 12h ago
[  OK  ] DietPi-Services | php7.3-fpm		active (running) since Sun 2020-07-05 10:46:03 BST; 12h ago
[  OK  ] DietPi-Services | nginx		active (running) since Sun 2020-07-05 23:38:03 BST; 3min 19s ago
[  OK  ] DietPi-Services | noip2		active (running) since Sun 2020-07-05 10:46:03 BST; 12h ago
[  OK  ] DietPi-Services | netdata		active (running) since Sun 2020-07-05 10:46:03 BST; 12h ago
[  OK  ] DietPi-Services | webmin		active (running) since Sun 2020-07-05 10:46:10 BST; 12h ago
[  OK  ] DietPi-Services | docker		active (running) since Sun 2020-07-05 10:46:10 BST; 12h ago
[  OK  ] DietPi-Services | cron			active (running) since Sun 2020-07-05 10:46:10 BST; 12h ago
[  OK  ] DietPi-Services | ssh			active (running) since Sun 2020-07-05 10:45:56 BST; 12h ago
[  OK  ] DietPi-Services | fail2ban		active (running) since Sun 2020-07-05 10:45:38 BST; 12h ago
[  OK  ] DietPi-Services | vncserver		active (exited) since Sun 2020-07-05 10:45:56 BST; 12h ago
[  OK  ] DietPi-Services | dietpi-ramlog	active (exited) since Sun 2020-07-05 10:45:36 BST; 12h ago
[  OK  ] DietPi-Services | dietpi-preboot	active (exited) since Sun 2020-07-05 10:45:38 BST; 12h ago
[  OK  ] DietPi-Services | dietpi-boot		active (exited) since Sun 2020-07-05 10:45:56 BST; 12h ago
[  OK  ] DietPi-Services | dietpi-postboot	active (exited) since Sun 2020-07-05 10:45:56 BST; 12h ago
User avatar
Joulinar
Posts: 2600
Joined: Sat Nov 16, 2019 12:49 am

Re: Change default landing page NGINX to Nextcloud

Post by Joulinar »

ok, I would recommend to redirect all traffic that will arrive on root URL to the nextcloud sub dir. For this, you would need to edit /etc/nginx/sites-available/default and change location section as follow

Code: Select all

location = / {
#               try_files $uri $uri/ =404;
                return 301 $scheme://your-site.com/nextcloud;  
}
Once done, restart Nginx

Code: Select all

systemctl restart nginx.service
Don't forget to clear browser cache.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
zartarr88
Posts: 20
Joined: Sun Jul 05, 2020 4:18 am

Re: Change default landing page NGINX to Nextcloud

Post by zartarr88 »

Dear Joulinar,
that fix worked for me , thank you kindly.
I'm reaching out regarding 'error chunk' in Nextcloud I get continuously.

based on my research I believe it has to do with redis-server not accurately set up.
Issue 1) my website went down after I did chown www-data something ; I need to fix config permissions and I'm not sure how to troubleshoot this.
i believe the culprit is "usermode -a -G redis www-data" a tip I found on a site

Issue 2) when I run systemctl status redis-server I get a few errors which I believe might be the culprits:

Code: Select all

Jul 08 21:01:32 DietPi redis[1568]: Warning: 32 bit instance detected but no memory limit set. Setting
 3 GB maxmemory limit with 'noeviction' policy now.
Jul 08 21:01:33 DietPi redis[1568]: WARNING: The TCP backlog setting of 511 cannot be enforced because
 /proc/sys/net/core/somaxconn is set to the lower value of 128.
Jul 08 21:01:33 DietPi redis[1568]: Server initialized
Jul 08 21:01:33 DietPi redis[1568]: WARNING overcommit_memory is set to 0! Background save may fail un
der low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the comm
and 'sysctl vm.overcommit_memory=1' for this to take effect.
User avatar
Joulinar
Posts: 2600
Joined: Sat Nov 16, 2019 12:49 am

Re: Change default landing page NGINX to Nextcloud

Post by Joulinar »

looks like this is quite a common issue https://help.nextcloud.com/t/unsolved-e ... -504/57205
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
zartarr88
Posts: 20
Joined: Sun Jul 05, 2020 4:18 am

Re: Change default landing page NGINX to Nextcloud

Post by zartarr88 »

In attempts to fix the chunking error I believe something broke:

Internal Server Error
The server was unable to complete your request.
If this happens again, please send the technical details below to the server administrator.
More details can be found in the server log.
Last edited by zartarr88 on Sun Jul 12, 2020 7:05 am, edited 1 time in total.
User avatar
Joulinar
Posts: 2600
Joined: Sat Nov 16, 2019 12:49 am

Re: Change default landing page NGINX to Nextcloud

Post by Joulinar »

can you check if all services are running? Looks like some something wrong with PHP
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
zartarr88
Posts: 20
Joined: Sun Jul 05, 2020 4:18 am

Re: Change default landing page NGINX to Nextcloud

Post by zartarr88 »

All services are running; this happened right after I did something with permissions and redis

systemctl redis:

Code: Select all

Jul 08 22:45:22 DietPi redis-server[597]: 597:C 08 Jul 2020 22:45:22.555 # Redis version=5.0.3, bits=32, commit=00000000, modi
fied=0, pid=597, just started
Jul 08 22:45:22 DietPi redis-server[597]: Redis version=5.0.3, bits=32, commit=00000000, modified=0, p
id=597, just started
Jul 08 22:45:22 DietPi redis-server[597]: 597:C 08 Jul 2020 22:45:22.556 # Configuration loaded
Jul 08 22:45:22 DietPi redis-server[597]: Configuration loaded
Jul 08 22:45:22 DietPi redis[598]: Warning: 32 bit instance detected but no memory limit set. Setting 
3 GB maxmemory limit with 'noeviction' policy now.
Jul 08 22:45:22 DietPi systemd[1]: redis-server.service: Can't open PID file /run/redis/redis-server.pid (yet?) after start: N
o such file or directory
Jul 08 22:45:22 DietPi redis[598]: WARNING: The TCP backlog setting of 511 cannot be enforced because 
/proc/sys/net/core/somaxconn is set to the lower value of 128.
Jul 08 22:45:22 DietPi redis[598]: Server initialized
Jul 08 22:45:22 DietPi redis[598]: WARNING overcommit_memory is set to 0! Background save may fail und
er low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the comma
nd 'sysctl vm.overcommit_memory=1' for this to take effect.
Jul 08 22:45:22 DietPi systemd[1]: Started Advanced key-value store.
ls -alt /run/redis/
- seems odd ; especially since its redis redis and not www-data here ?

Code: Select all

total 4
drwxr-xr-x 23 root  root  720 Jul  8 22:45 ..
drwxr-sr-x  2 redis redis  80 Jul  8 22:45 .
-rw-rw----  1 redis redis   4 Jul  8 22:45 redis-server.pid
srwxrwx---  1 redis redis   0 Jul  8 22:45 redis-server.sock
User avatar
Joulinar
Posts: 2600
Joined: Sat Nov 16, 2019 12:49 am

Re: Change default landing page NGINX to Nextcloud

Post by Joulinar »

btw I tested the same using lighttpd web server and could easily upload a 1GB file without issues

for me it looks some on redis

Code: Select all

root@DietPi3:/run/redis# ls -la
total 4
drwxr-sr-x  2 redis redis  80 Jul  9 01:25 .
drwxr-xr-x 23 root  root  660 Jul  9 01:25 ..
-rw-rw----  1 redis redis   4 Jul  9 01:25 redis-server.pid
srwxrwx---  1 redis redis   0 Jul  9 01:25 redis-server.sock
root@DietPi3:/run/redis#
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply