Internet connection doesn't work after a while. Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
slalo19
Posts: 14
Joined: Sat Jun 06, 2020 11:26 am

Internet connection doesn't work after a while.

Post by slalo19 »

Hi, I recently created a post in which I tried to solve a problem that after some time I couldn't connect to the local network via ssh or web. I thought I'd fixed it but I haven't. Now I can connect via ssh but the server has no internet connection. I've been frustrated for a month because I can't get it to work, the dmesg command brings up this which may be related to the problem:

Code: Select all

[108791.639833] wlan0: deauthenticating from d8:47:32:14:7f:10 by local choice (Reason: 3=DEAUTH_LEAVING)
[108793.660974] ath10k_pci 0000:01:00.0: Unknown eventid: 118809
[108793.663888] ath10k_pci 0000:01:00.0: Unknown eventid: 90118
[108797.618461] wlan0: authenticate with d8:47:32:14:7f:10
[108797.649060] wlan0: send auth to d8:47:32:14:7f:10 (try 1/3)
[108797.650369] wlan0: authenticated
[108797.652892] wlan0: associate with d8:47:32:14:7f:10 (try 1/3)
[108797.756888] wlan0: associate with d8:47:32:14:7f:10 (try 2/3)
[108797.787038] wlan0: RX AssocResp from d8:47:32:14:7f:10 (capab=0x1411 status=0 aid=1)
[108797.790728] wlan0: associated
[177313.871994] wlan0: deauthenticating from d8:47:32:14:7f:10 by local choice (Reason: 3=DEAUTH_LEAVING)
[177324.743336] ath10k_pci 0000:01:00.0: Unknown eventid: 118809
[177324.746325] ath10k_pci 0000:01:00.0: Unknown eventid: 90118
[177328.652485] wlan0: authenticate with d8:47:32:14:7f:10
[177328.683142] wlan0: send auth to d8:47:32:14:7f:10 (try 1/3)
[177328.684678] wlan0: authenticated
[177328.687051] wlan0: associate with d8:47:32:14:7f:10 (try 1/3)
[177328.791022] wlan0: associate with d8:47:32:14:7f:10 (try 2/3)
[177328.820478] wlan0: RX AssocResp from d8:47:32:14:7f:10 (capab=0x1411 status=0 aid=1)
[177328.823666] wlan0: associated
User avatar
Joulinar
Posts: 2020
Joined: Sat Nov 16, 2019 12:49 am

Re: Internet connection doesn't work after a while.

Post by Joulinar »

Hi,

how does network configuration looks like one your system is not able to access the web

Code: Select all

ip a
ip r
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
slalo19
Posts: 14
Joined: Sat Jun 06, 2020 11:26 am

Re: Internet connection doesn't work after a while.

Post by slalo19 »

It is connected by WiFi with the ip 192.168.1.110 without dhcp. The output that the commands show is:

Code: Select all

root@DietPi:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 40:9f:38:3f:65:e3 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.110/24 brd 192.168.1.255 scope global wlan0
       valid_lft forever preferred_lft forever
3: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
    link/none
    inet 10.8.1.15/24 brd 10.8.1.255 scope global tun0
       valid_lft forever preferred_lft forever
root@DietPi:~#

root@DietPi:~# ip r
0.0.0.0/1 via 10.8.1.1 dev tun0
default via 192.168.1.1 dev wlan0 onlink
10.8.1.0/24 dev tun0 proto kernel scope link src 10.8.1.15
128.0.0.0/1 via 10.8.1.1 dev tun0
192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.110
root@DietPi:~#
User avatar
Joulinar
Posts: 2020
Joined: Sat Nov 16, 2019 12:49 am

Re: Internet connection doesn't work after a while.

Post by Joulinar »

but everything is working now. Correct? Or do you have issues to connect to the web right in this moment? I see as well you have a VPN interface tun0 running. Maybe you have issues connecting to the web because your VPN is not working correctly?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
slalo19
Posts: 14
Joined: Sat Jun 06, 2020 11:26 am

Re: Internet connection doesn't work after a while.

Post by slalo19 »

Sure enough, I use dietpi-nordvpn and right now I don't have internet access. I have changed the vpn server and I already have an internet connection but I don't understand why it randomly stops working. What can I do to avoid losing the connection using the vpn?
User avatar
Joulinar
Posts: 2020
Joined: Sat Nov 16, 2019 12:49 am

Re: Internet connection doesn't work after a while.

Post by Joulinar »

Most probably your VPN is failing and therefore you don't have internet connection. It could happen that NordVPN disconnects. Just search the web, you will find a lot of entries on this. Maybe you should connect to this forum post. It's a request how to automatically reconnect to NordVPN.

viewtopic.php?f=9&t=7855
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply