Please update Deluge to 2.0.3 Topic is solved

Suggestions for features and software you would like to see in DietPi, goes here.
Post Reply
sdq
Posts: 2
Joined: Tue Jun 23, 2020 9:52 pm

Please update Deluge to 2.0.3

Post by sdq »

Hi,
is it possible to update Deluge to recent version like 2.0.3?

1.3.15 seems a bit outdated...

Thanks and best regards
User avatar
Joulinar
Posts: 2044
Joined: Sat Nov 16, 2019 12:49 am

Re: Please update Deluge to 2.0.3

Post by Joulinar »

Hi,

Many thanks for your message. I guess this will answer your question viewtopic.php?f=9&t=7475
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
dornt_
Posts: 11
Joined: Wed Jun 17, 2020 6:56 pm

Re: Please update Deluge to 2.0.3

Post by dornt_ »

Just an idea/suggestion to indirect solve the issue.

Use docker with a deluge image/container.

I run a deluge docker container in a NanoPi NEO2 with
1-bay NAS kit, not over DietPi but an OMV, that I said 'an
ideea/suggestion', for over two years without any problem.

And, because DietPi have the option to install Docker
through the 'dietpi-software' you just have to find a Deluge
image with a more recent version.

I think it's worth a try ... is on my list but with low priority
since my above configuration works.
I don't want to fix something that it works 😀
sdq
Posts: 2
Joined: Tue Jun 23, 2020 9:52 pm

Re: Please update Deluge to 2.0.3

Post by sdq »

dornt_ wrote: Tue Aug 11, 2020 10:12 pm Just an idea/suggestion to indirect solve the issue.

Use docker with a deluge image/container.

I think it's worth a try ... is on my list but with low priority
since my above configuration works.
I don't want to fix something that it works 😀
It works, at some level. (Frankly speaking, for me it doesn't work yet).

What image do you recommend?

Trackers reject the client because of 'weird' version Deluge advertises itself to the tracker (like from linuxserver/deluge - 2.0.3-2201906121747ubuntu18.04.1-ls75). It should advertise as 2.0.3 which is whitelisted on the allowed clients list.
Post Reply